HDU - 1009 FatMouse' Trade

FatMouse' Trade

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean. 
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain. 

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000. 

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain. 

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500

 

题意:

    一只肥老鼠有m磅猫粮,准备与猫交换它最喜欢的食物。第一行输入两个整数m和n,表示老鼠有m磅猫粮,猫的仓库有n个房间,接下来是n组数据,每组数据包括两个整数老鼠和猫交换的粮食数量,如第一组老鼠可以用2磅猫粮交换7磅粮食。计算出老鼠可以得到的最多粮食磅数。(老鼠真作死。。不怕被吃)

为了交换更多,明显的贪心

此处定义结构体,存放 交易的东西,以及他们的比例

按比例sort一下,取最大的就可以了。

 

#include <bits/stdc++.h>

using namespace std;

struct trade
{
    double j,f,r;
}s[1005];

bool compare(trade a,trade b)
{
    return a.r>b.r;
}

int main()
{
    int m,n;
    while(~scanf("%d%d",&m,&n))
    {
        double sum=0;
        if(m==n&&n==-1)
            break;
        for(int i=0;i<n;i++)
        {
            scanf("%lf%lf",&s[i].j,&s[i].f);
            s[i].r=s[i].j/s[i].f;
        }
        sort(s,s+n,compare);
        for(int i=0;i<n;i++)
        {
            if(m-s[i].f>=0)
            {
                sum=sum+s[i].j;
                m=m-s[i].f;
            }
            else
            {
                sum=sum+m*s[i].r;
                break;
            }
        }
        printf("%.3f\n",sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值