LightOJ 1282-求n^k的前三位和后三位

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

后3位好求,模一下就行了,关键是前3位。

我们可以这样考虑,对于任何一个数n,都有n = x*{10}^l,其中x为大于1的小数,其实就是一种科学计数法

我们知道,n的数位为log_{10}n,所以取科学计数法时,数位应为log_{10}n-1 .

对于n^k = x * 10^{len-1},有k*log_{10}n = (len-1)log_{10}x,即x = 10^{k*log_{10}n-len+1 },最后处理一下,把x扩大成3位就可以了。

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <iostream>
#include <map>
#include <vector>
#include <queue>
#include <set>
#define eps 1e-8
#define lson l,mid,pos<<1
#define rson mid+1,r,pos<<1|1
typedef long long ll;
const double PI = acos(-1.0);
const int maxn = 1e6;
const int INF = 1e9;
const ll linf = 0x3f3f3f3f3f3f3f3f;
using namespace std;
int qsm(int a, int b, int mod)
{
    int base = a%mod;
    int ans = 1;
    while(b)
    {
        if(b&1)
            ans = ans*base%mod;
        base = base*base%mod;
        b >>= 1;
    }
    return ans;
}
int main()
{
    int T;
    cin>>T;
    int tt = 1;
    while(T--)
    {
        ll n,k;
        cin>>n>>k;
        printf("Case %d: ",tt++);
        int len  = k*log10(n*1.0);
        double x = pow(10.0,k*1.0*log10(n*1.0)-len+1);
        while(x<100)
            x *= 10;
        int ans1 = x;
        int ans2 = qsm(n,k,1000);
        printf("%03d %03d\n",ans1,ans2);
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值