PAT-1007 Maximum Subsequence Sum

Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题意

最大子列和,只不过需要记录子列的开始和结束下标,此外对于有多个相同的子序和,应该选取较小的开始和结束下标;注意:如果输入数据所有的数据都是负数,那么输出子序和的大小为0,然后输出第一个数和最后一个数

思路:最大子序和,用sum记录累加的值,如果sum<0,那么舍弃之前的序列,即是sum = 0;对于需要记录子序列的开始和结束下标,因为结束下标是随着sum的累加而累加,而开始下标我们只需要设置temp_begin进行记录即可,当sum = 0时,重新更新temp_begin;

Code

#include <iostream>
using namespace std;

int numbers[10006];
int main()
{
    int n;
    cin >> n;
    int begin, last,temp_begin, sum;
    begin = last = temp_begin = sum = 0;
    // temp_begin 记录暂时的begin的下标
    int max = 0x80000000;

    for (int i = 0; i < n; i++)
    {
        cin >> numbers[i];
        sum += numbers[i];
        if (max < sum)
        {
            max = sum;
            begin = temp_begin;
            last = i;
        }
        if (sum < 0)
        {
            sum = 0;
            temp_begin = i + 1;
        }
    }
    if (max < 0)
    {
        max = 0;   // 输入数据的数全部为负数的时候,输出首项和尾项
        cout << max << " " << numbers[0] << " " << numbers[n - 1];
    }
    else
    {
        cout << max << " " << numbers[begin] << " " << numbers[last];
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值