双向链表的操作问题

建立一个长度为n的带头结点的双向链表,使得该链表中的数据元素递增有序排列。(必须使用双向链表完成,数据类型为整型。)
输入
第一行:双向表的长度; 第二行:链表中的数据元素。
输出
输出双向链表中的数据元素的值。
样例输入
10 2 4 6 3 5 8 10 21 12 9
样例输出
2 3 4 5 6 8 9 10 12 21
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
    int date;
    node *last;
    node *next;
};
int main()
{
    int n;
    while (cin >> n)
    {
        node *p = new node;
        node *s, *t;
        cin >> p->date;
        p->next = NULL;
        s = p;
        for(int i=1;i<n;i++)
        {
            t = new node;
            cin>>t->date;
            s->next = t;
            t->last = s;
            s = t;
        }
        s->next = NULL;
        t = p;
        while (t!=NULL) {
            s = t;
            while (s!=NULL) {
                if(t->date>s->date)
                {
                    int  temp;
                    temp = t->date;
                    t->date = s->date;
                    s->date = temp;
                }
                s = s->next;
            }
            t = t->next;
        }
        t = p;
        while (t != NULL)
        {
            cout << t->date << ' ';
            t = t->next;
        }
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值