PAT甲级刷题记录——1086 Tree Traversals Again (25分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

思路

这题其实就是根据前序+中序重建二叉树,然后寻找后序序列。不要被题目中什么通过栈能唯一确立一棵二叉树之类的所吓到,仔细分析一下就能发现,入栈的顺序就是二叉树的前序序列(Push 1 2 3 4 5 6),出栈出来的序列就是二叉树的中序序列(比如以样例来说,出栈序列就是3 2 4 1 6 5,就是这棵二叉树的中序序列)。

然后得到这两个序列之后,这题不也迎刃而解了~

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<stack>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn = 31;
struct node{
    int data;
    node* lchild;
    node* rchild;
};
int pre[maxn] = {0};
int in[maxn] = {0};
int preLen = 0, inLen = 0;
stack<int> tmp;
node* create(int preL, int preR, int inL, int inR){
    if(preL>preR){
        return NULL;
    }
    node* root = new node;
    root->data = pre[preL];
    int k;
    for(k=inL;k<=inR;k++){
        if(in[k]==pre[preL]) break;
    }
    int numLeft = k-inL;
    root->lchild = create(preL+1, preL+numLeft, inL, k-1);
    root->rchild = create(preL+numLeft+1, preR, k+1, inR);
    return root;
}
void postorder(node* root, int &cnt){
    if(root==NULL) return;
    postorder(root->lchild, cnt);
    postorder(root->rchild, cnt);
    if(cnt==0){
        printf("%d", root->data);
        cnt++;
    }
    else{
        printf(" %d", root->data);
        cnt++;
    }
}
int main(){
    int N;
    cin>>N;
    cin.ignore();//如果cin后面是getline操作,请记得吃掉换行符
    for(int i=0;i<2*N;i++){
        string temp;
        getline(cin,temp);
        if(temp.length()>3){//大于3位的长度,说明是Push操作
            int posSpace = temp.find(" ");
            string tmpnum = temp.substr(posSpace+1);
            int tmpNumber = stoi(tmpnum);
            tmp.push(tmpNumber);
            pre[preLen++] = tmpNumber;
        }
        else{
            in[inLen++] = tmp.top();
            tmp.pop();
        }
    }
    node* root = create(0, preLen-1, 0, inLen-1);
    int cnt = 0;
    postorder(root, cnt);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值