PAT甲级刷题记录——1029 Median (25分)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×105​ ) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

思路

这题非常简单,14分钟(包括读题时间)居然就AC了……

题目的大意就是让你找两个序列合并之后的中位数,并且根据题干可以看到,如果一个序列是偶数,那么它的中位数所在位置是序列长度/2(这里下标统一从1开始算,这样计算起来很简单),如果是奇数,那么它的中位数所在位置就是(序列长度+1)/2。于是,就能得到代码啦~

这里我选择用了一个数组,第二个序列直接先加在后面,然后对整个合并好的序列排个序(当然,用two pointers合并序列也行,但是我觉得先加在第一个序列后面,再用sort更简单一些),最后直接根据序列长度计算中位数所在位置就行了。

代码

#include<cstdio>
#include<stdlib.h>
#include<algorithm>
#include<string.h>
#include<iostream>
using namespace std;
const int maxn = 400010;
int data[maxn] = {0};
int main()
{
    int N1;
    scanf("%d", &N1);
    for(int i=1;i<=N1;i++){
        scanf("%d", &data[i]);
    }
    int N2;
    scanf("%d", &N2);
    for(int i=N1+1;i<=N1+N2;i++){
        scanf("%d", &data[i]);
    }
    sort(data+1, data+N1+N2+1);
    if((N1+N2)%2==0) printf("%d", data[(N1+N2)/2]);
    else printf("%d", data[(N1+N2+1)/2]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值