PAT甲级刷题记录——1084 Broken Keyboard (20分)

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _(representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:

7_This_is_a_test
_hs_s_a_es

Sample Output:

7TI

思路

这题是一个很简单的散列题哈,但是因为map和unordered_map的问题卡了一会……

题目意思很简单,就是给你两行字符串,第一行是你期望输出的字符串,第二行是实际输出的字符串,然后让你输出哪些键是坏掉的(也就是在实际输出字符串中并没有出现的字符)。

很简单,直接用map就好了,但是注意所有输出的键都要是大写,因此,在读入的时候最好把所有字符都转成大写,再用map来映射,这里转大写可以用C语言的标准库函数toupper()来写。

最后想说的是,因为题目要求输出的顺序是按读入顺序来的,但是呢,不管是map还是unordered_map里面键存储的顺序都不是这样的一个顺序(map是按键从小到大排序的,而unordered_map完全是乱序),因此,输出的时候千万不要读map,而是应该读原字符串(也就是第一行字符串),根据它的值是否仍未true来输出。

但是呢,读原字符串还有个问题,就是会输出重复的字母,比如输出三个T之类的(THIS和TEST),因此,我这里又用了一个map来确定当前字母是否已经输出过(脑回路清奇……)。

代码

#include<cstdio>
#include<cctype>
#include<stdlib.h>
#include<algorithm>
#include<map>
#include<string>
#include<string.h>
#include<iostream>
using namespace std;
map<char, bool> hashtable;
map<char, bool> hasOutput;
int main()
{
    string ori, output;
    getline(cin, ori);
    getline(cin, output);
    for(int i=0;i<ori.length();i++){
        ori[i] = toupper(ori[i]);
        hashtable[ori[i]] = true;
    }
    for(int i=0;i<output.length();i++){
        output[i] = toupper(output[i]);
        hashtable[output[i]] = false;
    }
    for(int i=0;i<ori.length();i++){
        if(hashtable[ori[i]]==true&&hasOutput[ori[i]]==false){
            cout<<ori[i];
            hasOutput[ori[i]] = true;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值