C语言基础编程题目(函数题)

题目地址:https://pintia.cn/problem-sets/14/problems

6-1 简单输出整数 (10 分)

本题要求实现一个函数,对给定的正整数N,打印从1到N的全部正整数。

函数接口定义:

void PrintN ( int N );

其中N是用户传入的参数。该函数必须将从1到N的全部正整数顺序打印出来,每个数字占1行。

裁判测试程序样例:

#include <stdio.h>

void PrintN ( int N );

int main ()
{
    int N;

    scanf("%d", &N);
    PrintN( N );

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

3

输出样例:

1
2
3

 

//6-1 简单输出整数
/* 你的代码将被嵌在这里 */
void PrintN ( int N )
{
	int i=0;
	for(i=1;i<N+1;i++)
	{
		printf("%d\n",i);
	}
} 

6-2 多项式求值 (15 分)

本题要求实现一个函数,计算阶数为n,系数为a[0] ... a[n]的多项式f(x)=\sum_{i=0}^{n}(a[i]*x^{i})x点的值。

函数接口定义:

double f( int n, double a[], double x );

其中n是多项式的阶数,a[]中存储系数,x是给定点。函数须返回多项式f(x)的值。

裁判测试程序样例:

#include <stdio.h>

#define MAXN 10

double f( int n, double a[], double x );

int main()
{
    int n, i;
    double a[MAXN], x;
	
    scanf("%d %lf", &n, &x);
    for ( i=0; i<=n; i++ )
        scanf(“%lf”, &a[i]);
    printf("%.1f\n", f(n, a, x));
    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

2 1.1
1 2.5 -38.7

输出样例:

-43.1

 

//6-2 多项式求值
/* 你的代码将被嵌在这里 */
double f( int n, double a[], double x )
{
	double sum=0;
	int i=0,j=0;
	
	for(i=0;i<n+1;i++)
	{
		sum+=a[i]*pow(x,i);
	}
	
	return sum;
}

//编译器警告
//[Warning] incompatible implicit declaration of built-in function 'pow' [enabled by default]

6-3 简单求和 (10 分)

本题要求实现一个函数,求给定的N个整数的和。

函数接口定义:

int Sum ( int List[], int N );

其中给定整数存放在数组List[]中,正整数N是数组元素个数。该函数须返回NList[]元素的和。

裁判测试程序样例:

#include <stdio.h>

#define MAXN 10

int Sum ( int List[], int N );

int main ()
{
    int List[MAXN], N, i;

    scanf("%d", &N);
    for ( i=0; i<N; i++ )
        scanf("%d", &List[i]);
    printf("%d\n", Sum(List, N));

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

3
12 34 -5

输出样例:

41
//6-3 简单求和
/* 你的代码将被嵌在这里 */
int Sum ( int List[], int N )
{
	int sum=0;
	int i=0;
	
	for(i=0;i<N;i++)
	{
		sum+=List[i];
	}
	
	return sum;
} 

 

6-4 求自定类型元素的平均 (10 分)

本题要求实现一个函数,求N个集合元素S[]的平均值,其中集合元素的类型为自定义的ElementType

函数接口定义:

ElementType Average( ElementType S[], int N );

其中给定集合元素存放在数组S[]中,正整数N是数组元素个数。该函数须返回NS[]元素的平均值,其值也必须是ElementType类型。

裁判测试程序样例:

#include <stdio.h>

#define MAXN 10
typedef float ElementType;

ElementType Average( ElementType S[], int N );

int main ()
{
    ElementType S[MAXN];
    int N, i;

    scanf("%d", &N);
    for ( i=0; i<N; i++ )
        scanf("%f", &S[i]);
    printf("%.2f\n", Average(S, N));

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

3
12.3 34 -5

输出样例:

13.77

 

//6-4 求自定类型元素的平均
/* 你的代码将被嵌在这里 */
ElementType Average( ElementType S[], int N )
{
	ElementType sum=0.0;
	int i=0;
	
	for(i=0;i<N;i++)
	{
		sum+=S[i];
	}
	
	return (ElementType)sum/N;
}

6-5 求自定类型元素的最大值 (10 分)

本题要求实现一个函数,求N个集合元素S[]中的最大值,其中集合元素的类型为自定义的ElementType

函数接口定义:

ElementType Max( ElementType S[], int N );

其中给定集合元素存放在数组S[]中,正整数N是数组元素个数。该函数须返回NS[]元素中的最大值,其值也必须是ElementType类型。

裁判测试程序样例:

#include <stdio.h>

#define MAXN 10
typedef float ElementType;

ElementType Max( ElementType S[], int N );

int main ()
{
    ElementType S[MAXN];
    int N, i;

    scanf("%d", &N);
    for ( i=0; i<N; i++ )
        scanf("%f", &S[i]);
    printf("%.2f\n", Max(S, N));

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

3
12.3 34 -5

输出样例:

34.00

 

//6-5 求自定类型元素的最大值
/* 你的代码将被嵌在这里 */
ElementType Max( ElementType S[], int N )
{
	ElementType max=S[0];
	int i=0;
	
	for(i=0;i<N;i++)
	{
		if(S[i]>max)
		{
			max=S[i];
		}
	}
	
	return max;
} 

 

6-6 求单链表结点的阶乘和 (15 分)

本题要求实现一个函数,求单链表L结点的阶乘和。这里默认所有结点的值非负,且题目保证结果在int范围内。

函数接口定义:

int FactorialSum( List L );

其中单链表List的定义如下:

typedef struct Node *PtrToNode;
struct Node {
    int Data; /* 存储结点数据 */
    PtrToNode Next; /* 指向下一个结点的指针 */
};
typedef PtrToNode List; /* 定义单链表类型 */

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

typedef struct Node *PtrToNode;
struct Node {
    int Data; /* 存储结点数据 */
    PtrToNode Next; /* 指向下一个结点的指针 */
};
typedef PtrToNode List; /* 定义单链表类型 */

int FactorialSum( List L );

int main()
{
    int N, i;
    List L, p;

    scanf("%d", &N);
    L = NULL;
    for ( i=0; i<N; i++ ) {
        p = (List)malloc(sizeof(struct Node));
        scanf("%d", &p->Data);
        p->Next = L;  L = p;
    }
    printf("%d\n", FactorialSum(L));

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

3
5 3 6

输出样例:

846
//6-6 求单链表结点的阶乘和
/* 你的代码将被嵌在这里 */
int FactorialSum( List L )
{
	int sum=0;
	int factorial=1;
	int i=0;
	List p=L; //p指向L的第一个节点 
	
	while(p)
	{
		factorial=1;
		for(i=1;i<=p->Data;i++)
		{
			factorial*=i;
		}
		sum+=factorial;
		p=p->Next;
	}
	
	return sum;
}

6-7 统计某类完全平方数 (20 分)

本题要求实现一个函数,判断任一给定整数N是否满足条件:它是完全平方数,又至少有两位数字相同,如144、676等。

函数接口定义:

int IsTheNumber ( const int N );

其中N是用户传入的参数。如果N满足条件,则该函数必须返回1,否则返回0。

裁判测试程序样例:

#include <stdio.h>
#include <math.h>

int IsTheNumber ( const int N );

int main()
{
    int n1, n2, i, cnt;
	
    scanf("%d %d", &n1, &n2);
    cnt = 0;
    for ( i=n1; i<=n2; i++ ) {
        if ( IsTheNumber(i) )
            cnt++;
    }
    printf("cnt = %d\n", cnt);

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

105 500

输出样例:

cnt = 6
//6-7 统计某类完全平方数
int IsTheNumber ( const int N )
{

    int m=N,a;

    a=(int)sqrt(N);
    if(a*a==N) //是完全平方数
    {
        int i;
        int num[10]={0};//数组初始化为0

        while(m>0)
        {
            for(i=0;i<10;i++) //int的最大值为2147483647
            {
                if(m%10==i)
                {
                    num[i]+=1;
                    if(num[i]==2)
                    {
                        return 1;
                    }
                }
            }
            m=m/10;
        }
        return 0;
    }
    return 0;
}

6-8 简单阶乘计算 (10 分)

本题要求实现一个计算非负整数阶乘的简单函数。

函数接口定义:

int Factorial( const int N );

其中N是用户传入的参数,其值不超过12。如果N是非负整数,则该函数必须返回N的阶乘,否则返回0。

裁判测试程序样例:

#include <stdio.h>

int Factorial( const int N );

int main()
{
    int N, NF;
	
    scanf("%d", &N);
    NF = Factorial(N);
    if (NF)  printf("%d! = %d\n", N, NF);
    else printf("Invalid input\n");

    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

5

输出样例:

5! = 120
//6-8 简单阶乘计算
int Factorial( const int N )
{
    int factorial=1;
    int i;
    if(N>0)
    {
        for(i=1;i<=N;i++)
        {
            factorial*=i;
        }
        return factorial;
    }
    else if(N==0)
        return 1;
    else
        return 0;
}

 

6-9 统计个位数字 (15 分)

本题要求实现一个函数,可统计任一整数中某个位数出现的次数。例如-21252中,2出现了3次,则该函数应该返回3。

函数接口定义:

int Count_Digit ( const int N, const int D );

其中ND都是用户传入的参数。N的值不超过int的范围;D是[0, 9]区间内的个位数。函数须返回ND出现的次数。

裁判测试程序样例:

#include <stdio.h>

int Count_Digit ( const int N, const int D );

int main()
{
    int N, D;
	
    scanf("%d %d", &N, &D);
    printf("%d\n", Count_Digit(N, D));
    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

-21252 2

输出样例:

3
//6-9 统计个位数字
int Count_Digit ( const int N, const int D )
{
    int a=N;
    int i;
    int cnt=0;

    if(a<0)
        a=-a;

    do
    {
        if(a%10==D)
        {
            cnt++;               
        }   
        a=a/10;
    }while(a>0);
    return cnt;
}

 

6-10 阶乘计算升级版 (20 分)

本题要求实现一个打印非负整数阶乘的函数。

函数接口定义:

void Print_Factorial ( const int N );

其中N是用户传入的参数,其值不超过1000。如果N是非负整数,则该函数必须在一行中打印出N!的值,否则打印“Invalid input”。

裁判测试程序样例:

#include <stdio.h>

void Print_Factorial ( const int N );

int main()
{
    int N;
	
    scanf("%d", &N);
    Print_Factorial(N);
    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

15

输出样例:

1307674368000

 

//6-10 阶乘计算升级版

 

  • 32
    点赞
  • 172
    收藏
    觉得还不错? 一键收藏
  • 6
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 6
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值