pat 甲级 树 A1066 Root of AVL Tree (25分)

1066 Root of AVL Tree (25分)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

 

 

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

 

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

 题意:类似1123,构建avl树,并输出根结点

#include<iostream>
#include<algorithm>
using namespace std;
typedef struct Node* node;
struct Node
{
    int data;
    node left,right;
};
node ll(node root)
{
    node t=root->right;
    root->right=t->left;
    t->left=root;
    return t;
}
node rr(node root)
{
    node t=root->left;
    root->left=t->right;
    t->right=root;
    return t;
}
node lr(node root)
{
    root->left=ll(root->left);
    return rr(root);
}
node rl(node root)
{
    root->right=rr(root->right);
        return ll(root);
}
int getHeight(node root)
{
    if(root==NULL) return 0;
    return max(getHeight(root->left),getHeight(root->right))+1;
}
node insert(node root,int data)
{
    if(root==NULL)
    {
        root=new Node;
        root->data=data;
        root->left=NULL;
        root->right=NULL;
        return root;
    }
    else if(data<root->data)
    {
        root->left=insert(root->left,data);
        if(getHeight(root->left)-getHeight(root->right)==2)
            root=data<root->left->data ? rr(root):lr(root);
    }
    else 
    {
        root->right=insert(root->right,data);
        if(getHeight(root->right)-getHeight(root->left)==2)
            root=data>root->right->data?ll(root):rl(root);
    }
    return root;
}
int main()
{
    int n,data;
    cin>>n;
    node root=NULL;
    for(int i=0;i<n;i++)
    {
        cin>>data;
        root=insert(root,data);
    }
    cout<<root->data<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值