pat 甲级 排序 A1153 Decode Registration Card of PAT (25分)

 

1153 Decode Registration Card of PAT (25分)

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA
#include<iostream>
#include<vector>
#include<unordered_map>
#include<algorithm>
#include<string>
using namespace std;
struct node{
	string t;
	int score;
};
bool cmp(node &a,node &b){
	return a.score!=b.score ? a.score >b.score :a.t<b.t ;
}
int main(){
	int n,m,k;
	string s;
    scanf("%d %d",&n,&m);
	vector<node> v(n);
	for(int i=0;i<n;i++){
		cin>>v[i].t>>v[i].score;
	}
	for(int i=1;i<=m;i++){
		vector<node> ans;
		int cnt=0;
		cin>>k>>s;
        printf("Case %d: %d %s\n",i,k,s.c_str());
		if(k==1){
			for(int j=0;j<v.size() ;j++)
				if(v[j].t.substr(0,1)==s) ans.push_back(v[j]);
		}
		else if(k==2){
			int sum=0;
			for(int j=0;j<v.size() ;j++){
				if(v[j].t.substr(1,3)==s){
					cnt++;
					sum+=v[j].score;
				}
			}
			if(cnt!=0) 
            printf("%d %d\n",cnt,sum);
		}
		else if(k==3){
			unordered_map<string,int> mp;
			for(int j=0;j<v.size() ;j++)
				if(v[j].t.substr(4,6)==s)
				mp[v[j].t.substr(1,3)]++;
				for(auto it:mp) ans.push_back({it.first,it.second});
		}
		sort(ans.begin(),ans.end(),cmp);
		if(((k==1||k==3)&&ans.size()==0)||(k==2&&cnt==0)) 
            printf("NA\n");
		else{
			for(int j=0;j<ans.size();j++){
                printf("%s %d\n",ans[j].t.c_str(),ans[j].score);
			}
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值