PAT甲级1046 Shortest Distance (20分)|C++实现

一、题目描述

原题链接
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

在这里插入图片描述

​​Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

二、解题思路

题目大意是:N个出口构成一个圈,给出每个出口离下个出口的距离,随后任意输入两个出口,要我们输出它们之间的最短距离。这道题目很好想,因为每个出口构成一个圈,我们的最短距离要么是按顺时针方向转过去,要么是按逆时针方向转过去。我们可以用数组fromSt表示每个出口离起点的距离(顺时针),那么,根据题目给出的两个出口,我们可以求出顺时针的距离,随后用整个圆的周长减去这个距离就是逆时针方向的距离,进行比较然后输出即可。

三、AC代码

#include<iostream>
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn = 100010;
int edge[maxn] = {0};   //存放第i条边的长度
int fromSt[maxn] = {0};
int N;
int main()
{
    int M, a, b, ans;
    scanf("%d", &N);
    for(int i=1; i<=N; i++)
    {
        scanf("%d", &edge[i]);
        fromSt[i] = fromSt[i-1] + edge[i-1];
    }
    scanf("%d", &M);
    for(int i=0; i<M; i++)
    {
        scanf("%d%d", &a, &b);
        int clock = fromSt[max(a, b)] - fromSt[min(a, b)];
        int counter = fromSt[N] + edge[N] - clock;
        ans = clock > counter ? counter : clock;
        printf("%d\n", ans);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值