PAT甲级1054 The Dominant Color (20分)|C++实现

一、题目描述

原题链接
Behind the scenes in the computer’s memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

在这里插入图片描述

​​Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

二、解题思路

20分简单题,统计各个数字出现的次数即可,我这里用了map,事实上用简单数组也可以实现。遍历map,找出比当前最大值大的即可。

三、AC代码

#include<iostream>
#include<set>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;
map<long long, int> mp;
int main()
{
    int M, N;
    long long tmp, most = -1;
    int cntMax = 0;
    scanf("%d%d", &M, &N);
    for(int i=0; i<N; i++)
    {
        for(int j=0; j<M; j++)
        {
            scanf("%d", &tmp);
            mp[tmp]++;
        }
    }
    for(auto it : mp)
    {
        if(it.second > cntMax)
        {
            cntMax = it.second;
            most = it.first;
        }
    }
    printf("%d", most);
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是基于 PCL(Point Cloud Library)库的 C++ 代码示例,使用 PCA 方法建立点云的局部坐标系: ```cpp #include <iostream> #include <pcl/point_types.h> #include <pcl/features/normal_3d.h> #include <pcl/filters/extract_indices.h> #include <pcl/filters/voxel_grid.h> #include <pcl/segmentation/sac_segmentation.h> #include <pcl/common/transforms.h> #include <pcl/visualization/pcl_visualizer.h> int main(int argc, char** argv) { // Load point cloud data pcl::PointCloud<pcl::PointXYZ>::Ptr cloud(new pcl::PointCloud<pcl::PointXYZ>); pcl::io::loadPCDFile<pcl::PointXYZ>("input_cloud.pcd", *cloud); // Apply voxel grid filtering to downsample the point cloud pcl::VoxelGrid<pcl::PointXYZ> voxel_grid; voxel_grid.setInputCloud(cloud); voxel_grid.setLeafSize(0.01f, 0.01f, 0.01f); pcl::PointCloud<pcl::PointXYZ>::Ptr cloud_downsampled(new pcl::PointCloud<pcl::PointXYZ>); voxel_grid.filter(*cloud_downsampled); // Estimate surface normals of the downsampled point cloud pcl::NormalEstimation<pcl::PointXYZ, pcl::Normal> normal_estimation; normal_estimation.setInputCloud(cloud_downsampled); pcl::search::KdTree<pcl::PointXYZ>::Ptr kd_tree(new pcl::search::KdTree<pcl::PointXYZ>); normal_estimation.setSearchMethod(kd_tree); pcl::PointCloud<pcl::Normal>::Ptr cloud_normals(new pcl::PointCloud<pcl::Normal>); normal_estimation.setRadiusSearch(0.03f); normal_estimation.compute(*cloud_normals); // Extract the dominant plane from the point cloud pcl::SACSegmentationFromNormals<pcl::PointXYZ, pcl::Normal> sac_segmentation; sac_segmentation.setOptimizeCoefficients(true); sac_segmentation.setModelType(pcl::SACMODEL_NORMAL_PLANE); sac_segmentation.setMethodType(pcl::SAC_RANSAC); sac_segmentation.setMaxIterations(1000); sac_segmentation.setDistanceThreshold(0.01); sac_segmentation.setInputCloud(cloud_downsampled); sac_segmentation.setInputNormals(cloud_normals); pcl::ModelCoefficients::Ptr coefficients(new pcl::ModelCoefficients); pcl::PointIndices::Ptr inliers(new pcl::PointIndices); sac_segmentation.segment(*inliers, *coefficients); // Extract the points of the dominant plane pcl::ExtractIndices<pcl::PointXYZ> extract_indices; extract_indices.setInputCloud(cloud_downsampled); extract_indices.setIndices(inliers); extract_indices.setNegative(false); pcl::PointCloud<pcl::PointXYZ>::Ptr plane_points(new pcl::PointCloud<pcl::PointXYZ>); extract_indices.filter(*plane_points); // Compute the centroid of the plane points Eigen::Vector4f centroid; pcl::compute3DCentroid(*plane_points, centroid); // Compute the covariance matrix of the plane points Eigen::Matrix3f covariance_matrix; pcl::computeCovarianceMatrixNormalized(*plane_points, centroid, covariance_matrix); // Compute the eigenvectors and eigenvalues of the covariance matrix Eigen::SelfAdjointEigenSolver<Eigen::Matrix3f> eigen_solver(covariance_matrix, Eigen::ComputeEigenvectors); Eigen::Matrix3f eigenvectors = eigen_solver.eigenvectors(); Eigen::Vector3f eigenvalues = eigen_solver.eigenvalues(); // Compute the rotation matrix to align the eigenvectors with the x, y, and z axes Eigen::Matrix4f transform_matrix = Eigen::Matrix4f::Identity(); Eigen::Matrix3f rotation_matrix = eigenvectors.transpose(); transform_matrix.block<3, 3>(0, 0) = rotation_matrix; // Transform the point cloud to align with the x, y, and z axes pcl::PointCloud<pcl::PointXYZ>::Ptr transformed_cloud(new pcl::PointCloud<pcl::PointXYZ>); pcl::transformPointCloud(*cloud_downsampled, *transformed_cloud, transform_matrix); // Visualize the original and transformed point clouds pcl::visualization::PCLVisualizer viewer("Point Cloud Viewer"); viewer.setBackgroundColor(0.0, 0.0, 0.0); pcl::visualization::PointCloudColorHandlerCustom<pcl::PointXYZ> original_color_handler(cloud_downsampled, 255, 255, 255); pcl::visualization::PointCloudColorHandlerCustom<pcl::PointXYZ> transformed_color_handler(transformed_cloud, 255, 0, 0); viewer.addPointCloud(cloud_downsampled, original_color_handler, "original_cloud"); viewer.addPointCloud(transformed_cloud, transformed_color_handler, "transformed_cloud"); viewer.setPointCloudRenderingProperties(pcl::visualization::PCL_VISUALIZER_POINT_SIZE, 1, "original_cloud"); viewer.setPointCloudRenderingProperties(pcl::visualization::PCL_VISUALIZER_POINT_SIZE, 1, "transformed_cloud"); viewer.addCoordinateSystem(0.1); viewer.initCameraParameters(); while (!viewer.wasStopped()) { viewer.spinOnce(); } return 0; } ``` 这个代码示例中使用了 PCL 库中的一些模块,包括: - `pcl::io::loadPCDFile()`:用于加载 PCD 文件中的点云数据。 - `pcl::VoxelGrid`:用于对点云进行下采样。 - `pcl::NormalEstimation`:用于估计点云的法向量。 - `pcl::SACSegmentationFromNormals`:用于从点云中提取主平面。 - `pcl::ExtractIndices`:用于从点云中提取指定索引的点。 - `pcl::compute3DCentroid`:用于计算点云的质心。 - `pcl::computeCovarianceMatrixNormalized`:用于计算点云的协方差矩阵。 - `Eigen::SelfAdjointEigenSolver`:用于计算协方差矩阵的特征向量和特征值。 - `pcl::transformPointCloud`:用于将点云进行旋转和平移操作。 - `pcl::visualization::PCLVisualizer`:用于可视化点云和坐标系。 具体实现过程可以参考代码中的注释。需要注意的是,这个代码示例只是一个简单的实现,实际应用需要根据具体情况进行修改和优化。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值