1135 Is It A Red-Black Tree (30 分) 红黑树

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

(1) Every node is either red or black.
(2) The root is black.
(3) Every leaf (NULL) is black.
(4) If a node is red, then both its children are black.
(5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.
For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.
在这里插入图片描述在这里插入图片描述在这里插入图片描述

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line “Yes” if the given tree is a red-black tree, or “No” if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

Note

  1. 题意: 一个avl树满足如下特点:根是黑的,相邻层之间的节点不同颜色,从任意节点到叶子节点的路径,黑色节点的个数相同
  2. 思路: 链表建树递归建树,dfs保证根到叶子黑色相同
  3. 没注意任意节点到叶子两个wa

Code

#include<iostream>
#include<vector>
#include<map>
#include<algorithm>
#include<fstream>
#include<cmath>
using namespace std;
vector <int> pre;
struct node{
    int data;
    struct node* left, *right;
};
node* build(node *root, int data){
    if(root == NULL){
		root = new node();
        root->data = data;
        root->left = root->right = NULL;
    }else if(abs(data) <= abs(root->data)){
        root->left = build(root->left, data);
    }else{
        root->right = build(root->right, data);
    }
    return root;
}
int black_num;
int flag = 0;
void Dfs( node* root, int cnt){
	if(flag == 1) return;
	if(root -> left == NULL && root -> right == NULL){
		if(root->data > 0)  
			cnt++;
		if(black_num < 0){ black_num =  cnt; }
		else if(cnt != black_num)
			flag = 1;
	}
	if(root -> left != NULL){
		if((root->data > 0 && root->left->data > 0) ||( root->left < 0 && root->left->data < 0))
			flag = 1;
		if(root->data > 0)
			Dfs(root->left, cnt+1);
		else
			Dfs(root->left, cnt);
	}
	if(root->right != NULL){
		if((root->data > 0 && root->right->data > 0) ||( root->right < 0 && root->right->data < 0))
			flag = 1;
		if(root->data > 0)
			Dfs(root->right, cnt+1);
		else
			Dfs(root->right, cnt);
	}

}

int main(){
#ifdef _DEBUG
	ifstream cin("data4.txt");
#endif
    int cases, num, i; 
    cin >> cases;
    while(cases--){
        cin >> num; 
		flag = black_num = -2;
        pre.resize(num);
        node *root = NULL;
        for(i = 0; i < num; i++){
            cin >> pre[i];
            root = build(root, pre[i]);
        }
		if(pre[0] < 0){ cout << "No" << endl; continue;}

		Dfs(root, 0);
		if(flag == 1) cout << "No" << endl;
		else cout << "Yes" << endl;
    }
#ifdef _DEBUG
	cin.close();
#endif
	return 0;
}
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值