1114 Family Property (25 分)

1114 Family Property (25 分)
This time, you are supposed to help us collect the data for family-owned property. Given each person’s family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child
​1
​​ ⋯Child
​k
​​ M
​estate
​​ Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID’s of this person’s parents (if a parent has passed away, -1 will be given instead); k (0≤k≤5) is the number of children of this person; Child
​i
​​ 's are the ID’s of his/her children; M
​estate
​​ is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:
For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG
​sets
​​ AVG
​area
​​

where ID is the smallest ID in the family; M is the total number of family members; AVG
​sets
​​ is the average number of sets of their real estate; and AVG
​area
​​ is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID’s if there is a tie.

Sample Input:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
Sample Output:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

给定一个人的id,父亲的id,母亲的id,所有孩子的id,他的房产数量和面积
输出家族的个数,相应的家族的信息

并查集的应用,找出所有联通块内,输出每个联通块内的最小id,成员个数,平均房产数量,平均房产面积

#include<bits/stdc++.h>
using namespace std;
map<string, string>parent, min_;
map<string, int>son, Num, Area;;
string find_(string x) {
	return parent[x] == "" ? x : find_(parent[x]);
}
void union_(string x, string y){
	string x_root = find_(x), y_root = find_(y);
	if (x_root == y_root) return;
	son[x_root] += son[y_root] + 1;
	Num[x_root] += Num[y_root];//有可能两个联通块会合并,所以需要
	Area[x_root] += Area[y_root];//联通块内的值整体赋给另一个连通块
	min_[x_root] = min(min_[x_root] == "" ? x_root : min_[x_root], min_[y_root] == "" ? y_root : min_[y_root]);
	parent[y_root] = x_root;//上面联通块的最小id也是在连通块合并的时候更新
}
int main()
{
	int n, m, num, area;
	cin >> n;
	string id, fa, ma, child;
	for (int i = 0; i < n; i++) {
		cin >> id >> fa >> ma>>m;
		if (ma != "-1") union_(ma, id);
		if (fa != "-1") union_(fa, id);
		for (int j = 0; j < m; j++) {
			cin >> child;
			union_(id, child);
		}
		cin >> num >> area;
		Num[find_(id)] += num;//都分别加到父节点上去
		Area[find_(id)] += area;//同上
	}
	struct family{
		string id;
		double num, set, area;
	};
	vector<family>ret;
	for (auto& it : parent)
		if (it.second == ""){
			if (min_[it.first] == "") min_[it.first] = it.first;
			double total = son[it.first] + 1;
			double ave_set = Num[it.first] / total, ave_area = Area[it.first] / total;
			ret.push_back(family{ min_[find_(it.first)],total,ave_set,ave_area });
		}
	sort(ret.begin(), ret.end(), [](family& a, family& b) {
		return a.area != b.area ? a.area > b.area:a.id < b.id;});
	cout << ret.size() << endl;
	for (auto& it : ret)
		printf("%s %.0f %.3f %.3f\n", it.id.c_str(), it.num, it.set, it.area);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值