1037 Magic Coupon (25分)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons N
​C
​​ , followed by a line with N
​C
​​ coupon integers. Then the next line contains the number of products N
​P
​​ , followed by a line with N
​P
​​ product values. Here 1≤N
​C
​​ ,N
​P
​​ ≤10
​5
​​ , and it is guaranteed that all the numbers will not exceed 2
​30
​​ .

Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3

Sample Output:
43
题意分析:
有一些商品和优惠券,均为整数,可以将优惠券用来购买商品,获得的价值是商品的值乘以优惠券的值,商品和优惠券只能使用一次,返回能获得的最大值。
将商品和优惠券都按正数和负数分类,并排序,用正数的优惠券用在正数的商品,负数的优惠券用在负数的商品上。

#include<bits/stdc++.h>
using namespace std;
int main()
{
	int n, a,ret=0;
	cin >> n;
	vector<vector<int>>data(4);
	for (int i = 0; i < n; i++)
	{
		cin >> a;
        data[a>0?0:2].push_back(a);
	}
	cin >> n;
	for (int i = 0; i < n; i++)
	{
		cin >> a;
        data[a>0?1:3].push_back(a);
	}
	for (int i = 0; i < 2; i++)
		sort(data[i].rbegin(), data[i].rend());
    for (int i = 2; i < 4; i++)
	    sort(data[i].begin(), data[i].end());
	for (int i = min(data[0].size(), data[1].size())-1; i >=0; i--)
		ret += data[0][i] * data[1][i];
	for (int i = min(data[2].size(), data[3].size())-1; i >=0; i--)
		ret += data[2][i] * data[3][i];
	cout << ret;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值