Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.
Input Specification:
Each input file contains one test case, which gives the integer N (1<N<2
31
).
Output Specification:
For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]factor[2]…*factor[k], where the factors are listed in increasing order, and 1 is NOT included.
Sample Input:
630
Sample Output:
3
567
枚举整个过程 ,将小于等于sqrt(num)的数依次作为首元素,计算连续的因子并更新最长的序列
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
int num;
cin >> num;
int max_value = sqrt(num);
pair<int,int>ret(0, 0);
for (int i = 2; i <= max_value; i++){
int tmp = num, last = i - 1, start = i, j;
for (j = i; tmp % j == 0 && j - last == 1; tmp /= j, last = j, j++);
if (j - start > ret.second - ret.first)
ret = { start,j };
}
if (ret.second - ret.first > 0){
cout << ret.second - ret.first << endl<<ret.first;
for (int i = ret.first+1; i < ret.second; i++)
cout << "*"<<i;
}
else
cout << 1 << endl << num << endl;
return 0;
}