1096 Consecutive Factors(20 分)(C++)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2​31​​).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7

本题的难度还是不小的,一开始题目也没读懂。。。

题目大意:给一个数,找他的最大的一个满足能拆分成连续数字乘积的约数。

解题思路:暴力破解

首先先判断一下2^31最多为12的阶乘,所以我们最多乘12个数,所以从最12个连续数的乘积开始判断,不存在则继续判断11个连续数乘积是否有满足为原数的约数。

#include <iostream>
#include <cmath>
using namespace std;
int main(){
    int x;
    cin>>x;
    for(int len = 13; len >= 1; --len){
        for(int i = 2; i <= sqrt(x); i ++ ){
            long long int sum = 1;
            for(int j = i; j < len + i; j++)
                sum *= j;
            if(x % sum == 0){
                printf("%d\n%d",len,i);
                for(int k = i+1; k < len+i; k++)
                    printf("*%d",k);
                return 0;
            }
        }
    }
    printf("1\n%d",x);
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值