PAT甲级——1147 Heaps【30】

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:
3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:
Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

第一种方法,比较笨,重建整棵树,然后判断是否时大根堆和小根堆,然后再遍历出后序遍历

#include <iostream>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
int n, m;
vector<int>level, post;
struct Node
{
    int val;
    Node *l, *r;
    Node(int a = 0) :val(a), l(nullptr), r(nullptr) {}
};
Node* creatTree(bool &flag, const bool isMax)
{
    Node* root = new Node(level[0]);
    int k = 1;
    queue<Node*>q;
    q.push(root);
    while (k < m)
    {
        Node *p = q.front();
        q.pop();
        p->l = new Node(level[k++]);
        if (isMax && p->val<p->l->val || !isMax && p->val>p->l->val)
            flag = false;
        q.push(p->l);
        if (k >= m)break;
        p->r = new Node(level[k++]);
        if (isMax && p->val < p->r->val || !isMax && p->val > p->r->val)
            flag = false;
        q.push(p->r);
    }
    return root;
}
void postOrder(Node *root)
{
    if (root == nullptr)
        return;
    postOrder(root->l);
    postOrder(root->r);
    post.push_back(root->val);
}
int main()
{
    cin >> n >> m;
    while (n--)
    {
        level.clear();
        level.resize(m);
        post.clear();
        int minN = INT32_MAX, maxN = -1;
        for (int i = 0; i < m; ++i)
        {
            cin >> level[i];
            minN = minN < level[i] ? minN : level[i];
            maxN = maxN > level[i] ? maxN : level[i];
        }
        bool flag = true, isMax = false;
        Node *root = nullptr;
        if (level[0] == minN)//小根堆
        {
            isMax = false;
            root = creatTree(flag, isMax);
        }
        else if (level[0] == maxN)
        {
            isMax = true;
            root = creatTree(flag, isMax);
        }
        else
        {
            flag = false;
            root = creatTree(flag, isMax);
        }
        postOrder(root);
        if (flag && isMax)
            printf("Max Heap\n");
        else if (flag && !isMax)
            printf("Min Heap\n");
        else
            printf("Not Heap\n");
        for (int i = 0; i < m; ++i)
            cout << (i == 0 ? "" : " ") << post[i];
        cout << endl;
    }
    return 0;
}

第二种方法,简单点,通过完全二叉树的性质,直接判断并得出后序遍历结果

#include <iostream>
#include <vector>
using namespace std;
int n, m;
vector<int>level, post;
void postOrder(int index)
{
    if (index >= m)return;
    postOrder(index * 2 + 1);
    postOrder(index * 2 + 2);
    post.push_back(level[index]);
}
int main()
{
    cin >> n >> m;
    while (n--)
    {
        level.resize(m);
        for (int i = 0; i < m; ++i)
            cin >> level[i];
        bool isMaxHeap = level[0] >= level[1] ? true : false;
        bool flag = true;
        for (int i = 0; i < (m - 1) / 2 && flag; ++i)
        {
            int L = i * 2 + 1, R = i * 2 + 2;
            if (isMaxHeap && (level[i] < level[L] || R < m && level[i] < level[R]))
                flag = false;
            if (!isMaxHeap && (level[i] > level[L] || R<m && level[i] > level[R]))
                flag = false;
        }
        if (flag && isMaxHeap)
            printf("Max Heap\n");
        else if (flag && !isMaxHeap)
            printf("Min Heap\n");
        else
            printf("Not Heap\n");
        postOrder(0);
        for (int i = 0; i < m; ++i)
            cout << (i == 0 ? "" : " ") << post[i];
        cout << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值