1155 Heap Paths (30 point(s))

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

题目大意:给一课完全二叉树,让你打印从跟到叶子的路径(从左到右),并判断是否为大小根堆

分析:

1)如何打印路径:

采用“先序”-》根/右/左 的的顺便遍历完全二叉树,每访问一个结点(push进容器),遇到叶子节点则顺序打印容器中的元素。然后回溯(一定要回溯),遍历右子树同样做法。

2)大小根堆判断

若父节点 > 孩子节点,则不是小根堆;

若父节点 < 孩子节点,则不是大根堆。

若非大小根堆,则输出非堆;

由于给的是完全二叉树,可从下标1~N入读顺序,建立index(父节点)~index*2(左孩子)~index*2+1(右孩子)的索引关系,方便处理。

完整代码:

#include<bits/stdc++.h>
using namespace std;
vector<int>v;
int n;
int a[1010];
void dfs(int index){
	if(index*2>n && index*2+1>n){
		if(index<=n){
		for(int i=0;i<v.size();i++){
			printf("%d%s",v[i],i==v.size()-1? "\n":" ");	
		}
	}
	}else{
		v.push_back(a[index*2+1]);
		dfs(index*2+1);
		v.pop_back();
		v.push_back(a[index*2]);
		dfs(index*2);
		v.pop_back();
	}
}

int main(){
	cin>>n;	
	for(int i=1;i<=n;i++){
		cin>>a[i];
	}
	v.push_back(a[1]);
	dfs(1);
	//大小根堆判断:
	bool max=true,min=true;
	for(int i=1;i<n/2;i++){
		if(a[i]>a[i*2] || a[i]>a[i*2+1]) min=false;
		if(a[i]<a[i*2] || a[i]<a[i*2+1]) max=false;
	} 
	if(max) cout<<"Max Heap";
	else if(min) cout<<"Min Heap";
	else cout<<"Not Heap";
	return 0;
}
	

进阶版例题:打印给定点权之和的路径

That’s all !

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZCAIHUI_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值