Traffic
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K
Problem Description
Avin is observing the cars at a crossroads. He finds that there are n cars running in the east-west direction with the i-th car passing the intersection at time ai . There are another m cars running in the north-south direction with the i-th car passing the intersection at time bi . If two cars passing the intersections at the same time, a traffic crash occurs. In order to achieve world peace and harmony, all the cars running in the north-south direction wait the same amount of integral time so that no two cars bump. You are asked the minimum waiting time.
Input
The first line contains two integers n and m (1 ≤ n, m ≤ 1, 000). The second line contains n distinct integers ai (1 ≤ ai ≤ 1, 000). The third line contains m distinct integers bi (1 ≤ bi ≤ 1, 000).
Output
Print a non-negative integer denoting the minimum waiting time.
Sample Input
1 1
1
1
1 2
2
1 3
Sample Output
1
0
题意
题目是说有东西和南北两个方向的车,东西方向的车只需按照自己原来的时间经过交叉路口即可,而南北方向的所有车必须等待相同的时间,然后两个方向的车都开始行驶,但不会发生任何碰撞,即要从 0 开始找到一个时间 t 加到南北方向上所有车的通过时间上,若都没有和东西方向的车发生碰撞,则说明该 t 就是最短的等待时间。
代码
#include<bits/stdc++.h>
using namespace std;
int a[3005],b[2005];
int main()
{
int n,m;
while(cin>>n>>m)
{
int k;
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
for(int i=0;i<n;i++) {cin>>k; a[k]=1;}//将东西向的车通过的时间标记下来
for(int i=0;i<m;i++) cin>>b[i];//输入南北向车的时间
for(int i=0; ;i++)
{
int f=0;
for(int j=0;j<m;j++)//判断是不是南北向所有的车在等待 t 时间后都不会和东西向的车相撞
{
if(a[b[j]+i]==1)//相撞
{
f=1;break;
}
}
if(f==0)//都没有相撞,满足条件,输出最小的等待时间
{
cout<<i<<endl;break;
}
}
}
return 0;
}