Tensorflow-gpu搭建CUDA 10.0与cuDNN等版本问题

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/weixin_42718092/article/details/85001140

首先看一下CUDA版本与linux下所用显卡驱动版本的关系和windows下所用显卡驱动的版本 ,参考如下:
https://blog.csdn.net/weixin_42718092/article/details/86016973
这篇文章列出的是官网给出的对应版本关系。

在这里插入图片描述
自己这两天一直在搭建Tensorflow-gpu这样一个环境。
tensorflow-gpu版本为1.12 ,如官方所示要求cuDNN版本为7,CUDA版本为9.
但自己在安装CUDA的时候一直是无法安装的状态,查看了很多其他人的博客,有好多都说是卸载现有的显卡驱动,然后再重新安装。不知道这样带来的后果是什么所以还是没有选择这样做。然后看到了官网上新出了CUDA v10的版本,然后直接下载安装了。我的电脑并没有安装VS2015,但是安装了VS2017和VS2013两个版本。并且CUDA 在最后安装成功的界面中,也提示了VS2015没有找到。但是测试下来,好像并不影响使用。
在这里插入图片描述
在这里插入图片描述
如上两个安装包,官网下载即可。cuda和cudnn的版本一定要对应好,官网上也给出了明确的对应关系。
还有一个问题是自己用Anaconda 安装的python,还在Anaconda里又创建了一个tensorflow的环境。两个python的版本有所不同。还是安装python3.5会更好一些。区别如下:
python3.65版本
在每次调用模块时总会提示这样一个错误,查看了很多博客,很多人说是numpy的版本过高。下面是3.5版本的:
在这里插入图片描述
不再提示错误,真的很开心。自己用Tensorflow这个框架没几天,但发现问题真是太多了。版本更新很快,有些老版本的命令直接被弃用了,有的函数的输入参数方式也是改变了(改变很大),在以后也应该尝试一下其他的框架。
知识是自己的,只有自己一点点解决才是正道,以前总想着问一些前辈,但态度真的是很差,问个一两次就不再想问了,可能也不是每个前辈都这样吧。
自己解决问题虽慢,但一旦解决还是很开心的。

展开阅读全文

没有更多推荐了,返回首页