排名 STL练习C++题解
Time limit:1000 ms Memory limit:32768 kB描述
今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的考生,并将他们的成绩按降序打印。
输入
测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N< 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号(题目号由1到M)。
当读入的考生人数为0时,输入结束,该场考试不予处理。
输出
对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考号的升序输出。
样例输入
4 5 25
10 10 12 13 15
CS004 3 5 1 3
CS003 5 2 4 1 3 5
CS002 2 1 2
CS001 3 2 3 5
1 2 40
10 30
CS001 1 2
2 3 20
10 10 10
CS000000000000000001 0
CS000000000000000002 2 1 2
0
样例输出
3
CS003 60
CS001 37
CS004 37
0
1
CS000000000000000002 20
注意
Huge input, scanf is recommended.
代码
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <map>
#include <stack>
#include <queue>
#include <cmath>
#include <set>
#include <ctype.h>
#include <stdio.h>
#define PI 3.14159265358979383246
#define LL long long
#define _for(i, a) for(int i = 0; i < (a); ++i)
#define _rep(i, a, b) for(int i = (a); i < (b); ++i)
using namespace std;
struct student {
char number[21];//学号
int m;//做出的题数
int sum;//总得分
};
struct cmpFunctor {
inline bool operator()(const student &a, const student &b) {
if (a.sum != b.sum) return a.sum > b.sum;
else return strcmp(a.number, b.number) < 0;
}
};
int main() {
int n = 0, m = 0, g = 0;
while (scanf("%d", &n), n) {
vector<struct student> a;
struct student temp;
int mg[10];//各题的分数
int x = 0;//缓存做出的题号
scanf("%d%d", &m, &g);
//cin >> m >> g;
//cout << n << endl << m << endl << g;
_for(i, m) {
scanf("%d", &mg[i]);
//cin >> mg[i];
}
//_for(i, m) {
// cout << mg[i] << ' ';
//}
_for(i, n) {
scanf("%s", temp.number);
//cin >> temp.number;
scanf("%d", &temp.m);
//cin >> temp.m;
temp.sum = 0;
_for(j, temp.m) {
scanf("%d", &x);
//cin >> x;
temp.sum += mg[x - 1];
}
if (temp.sum >= g)
a.push_back(temp);
}
//检验获取的数据
//_for(i, n) {
// cout << a[i].number << '-' << a[i].sum << endl;
//}
printf("%d\n", a.size());
//cout << a.size() << endl;
sort(a.begin(), a.end(), cmpFunctor());
_for(i, a.size()) {
printf("%s %d\n", a[i].number, a[i].sum);
//cout << a[i].number << ' ' << a[i].sum << endl;
}
}
return 0;
}
本人也是新手,也是在学习中,勿喷
转载请注明出处
欢迎有问题的小伙伴一起交流哦~