Heavy Transportation(最短路)

Heavy Transportation(最短路)

Time limit:3000 ms
Memory limit:30000 kB
OS:Linux
judge:https://vjudge.net/contest/297882#problem/C

描述

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

题意

雨果重很高兴。在卡戈利夫特项目崩溃后,他现在可以扩大业务了。但他需要一个聪明的人告诉他,从他客户建造巨型钢吊车的地方到所有街道都能承受重量的地方,是否真的有办法。

幸运的是,他已经制定了一个城市规划,包括所有街道和桥梁以及所有允许的重量。不幸的是,他不知道如何找到最大重量,以便告诉他的客户起重机可能变得有多重。但你肯定知道。

问题

根据交叉口之间的街道(有重量限制)描述的城市平面图,编号从1到N。您的任务是找到可以从交叉口1(雨果所在地)运输到交叉口N(客户所在地)的最大重量。您可以假定至少有一条路径。所有街道都可以双向行驶。

输入

第一行包含场景数量(城市规划)。每条城市的街道交叉口数量n(1<=n<=1000)和街道数量m在第一行给出。下面的m行包含三个整数,指定街道的起点和终点交叉点以及最大允许重量,这是正的,不大于1000000。每对交叉口之间最多有一条街道。

输出

每个场景的输出以包含“scenario_i:”的行开始,其中i是从1开始的场景数。然后打印一行包含雨果可以运输给客户的最大允许重量。用空行终止方案的输出。

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

代码

#include <iostream>
#include <algorithm>
#include <queue>
#include <vector>
#define _for(i, a) for(int i = 0; i < (a); i++)
#define _rep(i, a, b) for(int i = (a); i <= (b); i++)
#define maxn 1005
#define inf 0x3f3f3f3f
using namespace std;
struct poi {
	int v, w;
	poi() {}
	poi(int v, int w) :v(v), w(w) {}
	bool operator < (const poi tem) const {
		return w < tem.w;
	}
};
int n, m;
int dis[maxn];
bool vis[maxn];
vector<poi> mp[maxn];
void SPFA() {
	priority_queue<int> que;
	dis[1] = inf;
	vis[1] = 1;
	que.push(1);
	while (que.size()) {
		int tem = que.top();
		que.pop();
		vis[tem] = 0;
		_for(i, mp[tem].size()) {
			if (dis[mp[tem][i].v] < min(dis[tem], mp[tem][i].w)) {
				dis[mp[tem][i].v] = min(dis[tem], mp[tem][i].w);
				if (!vis[mp[tem][i].v]) {
					que.push(mp[tem][i].v);
					vis[mp[tem][i].v] = 1;
				}
			}
		}
	}
}
int main() {
	//freopen("in.txt", "r", stdin);
	int T;
	scanf("%d", &T);
	_rep(q, 1, T) {
		_for(i, maxn) dis[i] = -1;
		_for(i, maxn) mp[i].clear();

		scanf("%d%d", &n, &m);
		_for(i, m) {
			int a, b, c;
			scanf("%d%d%d", &a, &b, &c);
			mp[a].push_back(poi(b, c));
			mp[b].push_back(poi(a, c));
		}
		SPFA();
		printf("Scenario #%d:\n%d\n\n", q, dis[n]);
	}
	return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值