Heavy Transportation (dp)

C - Heavy Transportation
Time Limit:3000MS    Memory Limit:30000KB    64bit IO Format:%I64d & %I64u

Description

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

题意: 题目给出一个道路的图和每条道路最大载重.问从一号节点运送货物到n号节点最大可以运送的货物重量.

题解: 一开始看题目以为是网络流,看了样例后发现其实就是一个最短路的变形,要求找出一条道路,使运送的货物量达到最大. 以d[i] < min(d[u],w)表示从1号点到i点最大可以运送
的重量,则它会等于新加入的边和原来的边的最小值; 

AC代码:
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <vector>
#include <cmath>
#include <queue>
#include <map>
#include <set>
#define eps 1e-9

using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int M = 1100;
const int INF = 0x3f3f3f3f;
vector<P>G[M];
int d[M],vis[M],n;

struct Node{
    int d,x;
    Node(int d,int x):d(d),x(x){}
    bool operator<(const Node &a) const{
        return a.d > d;
    }
};

int dijkstra(){
    memset(vis,0,sizeof(vis));
    for(int i = 1; i <= n; i++) d[i] = -1;
    priority_queue<Node>mp;
    mp.push(Node(INF,1));
    d[1] = INF;
    while(mp.size()){
        Node now = mp.top();
        mp.pop();
        int u = now.x;
        if(vis[u]) continue;
        vis[u] = 1;
        for(int i = 0; i < G[u].size(); i++){
            P k = G[u][i];
            if(!vis[k.first] && d[k.first] < min(d[u],k.second)){
                d[k.first] = min(d[u],k.second);
                mp.push(Node(d[k.first],k.first));
            }
        }
    }
    return d[n];
}

int main(){
    int t,m,cnt = 0;
    cin>>t;
    while(t--){
        printf("Scenario #%d:\n",++cnt);
        cin>>n>>m;
        while(m--){
            int a,b,c;
            scanf("%d %d %d",&a,&b,&c);
            G[a].push_back(make_pair(b,c));
            G[b].push_back(make_pair(a,c));
        }
        printf("%d\n\n",dijkstra());
        for(int i = 1; i <= n; i++) G[i].clear();
    }
    return 0;
}



 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值