POJ练习题1001

题目描述

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don’t print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592 9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

limit

Time Limit: 500MS Memory Limit: 10000K

分析与理解

这道题考点是高精度大数计算 R n R^n Rn,空间不溢出,且可以计算到小数点后很多位
因为Java.math包中有BigDecimal类,(关于BigDecimal的介绍,可以参考Java BigDecimal详解 特此感谢博主LeoBoy)
所以我使用Java语言
代码如下:

import java.io.*;
import java.util.*;
import java.math.*;
import java.lang.*;
import java.text.*;
class Main
{
    public static void main(String[] argc)
    {
        Scanner in=new Scanner(System.in);
        BigDecimal a;
        int n;
        String s;
        while(in.hasNextBigDecimal())
        {
            a=in.nextBigDecimal();
            n=in.nextInt();
            a=a.pow(n);
            s=a.stripTrailingZeros().toPlainString();
            if(s.startsWith("0."))s=s.substring(1);
            System.out.println(s);
        }
    }
}

运行结果

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值