Count the Sheep——思维

Count the Sheep

Altough Skipping the class is happy, the new term still can drive luras anxious which is of course because of the tests! Luras became worried as she wanted to skip the class, as well as to attend the BestCoder and also to prepare for tests at the same time.

However, As the result of preparing for tests, luras had no time to practice programing. She didn’t want to lose her rating after attending BC. In the end, she found BCround92’s writer snowy_smile for help, asking him to leak her something.

Snowy_smile wanted to help while not leaking the problems. He told luras, the best thing to do is to take a good rest according to the following instructions first.

“Imagine you are on the endless grassland where there are a group of sheep. And n sheep of them are silent boy-sheep while m sheep are crying girl-sheep. And there are k friend-relationships between the boy-sheep and girl-sheep.Now You can start from any sheep, keep counting along the friend relationship. If you can count 4 different sheep, you will exceed 99% sheep-counters and fall asleep.”

Hearing of the strange instructions, luras got very shocked. Still, she kept counting. Sure enough, she fell asleep after counting 4 different sheep immediately. And, she overslept and missed the BestCoder in the next day. At a result, she made it that not losing her rating in the BCround92!!!

However, you don’t have the same good luck as her. Since you have seen the 2nd problem, you are possible to have submitted the 1st problem and you can’t go back.

So, you have got into an awkward position. If you don’t AC this problem, your rating might fall down.

You question is here, please, can you tell that how many different 4-sheep-counting way luras might have before her sleep?

In another word, you need to print the number of the “A-B-C-D” sequence, where A-B, B-C, C-D are friends and A,B,C,D are different.
Input
The first line is an integer T which indicates the case number.

and as for each case, there are 3 integers in the first line which indicate boy-sheep-number, girl-sheep-number and friend-realationship-number respectively.

Then there are k lines with 2 integers x and y in each line, which means the x-th boy-sheep and the y-th girl-sheep are friends.

It is guaranteed that——

There will not be multiple same relationships.

1 <= T <= 1000

for 30% cases, 1 <= n, m, k <= 100

for 99% cases, 1 <= n, m, k <= 1000

for 100% cases, 1 <= n, m, k <= 100000
Output
As for each case, you need to output a single line.

there should be 1 integer in the line which represents the number of the counting way of 4-sheep-sequence before luras’s sleep.
Sample Input
3
2 2 4
1 1
1 2
2 1
2 2
3 1 3
1 1
2 1
3 1
3 3 3
1 1
2 1
2 2
Sample Output
8
0
2

题解:

因为匹配的关系,很容就往二分图方向去思考了。因为要组成4个不同的羊。我们先观察一组匹配关系,然后公羊衍生一条母羊,母羊衍生一条公羊,然后就组成了4个,最后答案乘2就行了。

#include <bits/stdc++.h>
#define int long long
using namespace std;
const int N=1e5+7;
pair<int,int> pp[N];
int d1[N],d2[N];

signed main()
{
    int t; scanf("%d",&t);
    while(t--){
        int n,m,k;
        scanf("%d%d%d",&n,&m,&k);
        memset(d1,0,sizeof d1);
        memset(d2,0,sizeof d2);
        for(int i=1;i<=k;i++){
            scanf("%d%d",&pp[i].first,&pp[i].second);
            d1[pp[i].first]++;
            d2[pp[i].second]++;
        }
        int ans=0;
        for(int i=1;i<=k;i++){
            ans+=((d1[pp[i].first]-1)*(d2[pp[i].second]-1));
        }
        cout<<(ans<<1)<<endl;
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值