PAT_(STL使用)1039 Course List for Student (25分) 1047 Student List for Course (25分)

目录

1039 Course List for Student (25分)

1047 Student List for Course (25分)


 

1039 Course List for Student (25分)

Zhejiang University has 40000 students and provides 2500 courses.

Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses.

Then the student name lists are given for the courses (numbered from 1 to K) in the following format:

for each course i, first the course index i and the number of registered students N​i​​ (≤200) are given in a line.

Then in the next line, N​i​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number.

Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines.

Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

题意:N个学生,K门课,给出每门课的学生选课名单,查询N个学生每个人的选课情况

思路1:字符串hash+vector

思路2:unordered_map<string,vector<int>> stu

这两种思路的本质是一样的,字符串hash,

#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<string>
#include<cstring>
#include<vector>
#include<map>
#include<cmath>
#define pb push_back 
using namespace std;
const int maxn=26*26*26*10+10;
vector<int> stu[maxn]; //stu_name -hash-> id ->vector[id].pb(课程编号)
int getid(char name[]){
	int ans=0;
	for(int i=0;i<3;i++){
		ans=ans*26+(name[i]-'A');
	}
	ans=ans*10+(name[3]-'0');
	return ans;
}
 
int main(){
	int n,k;
	scanf("%d %d",&n,&k);
	int courseid,num; 
	char name[5];int id;
	for(int i=0;i<k;i++){
		scanf("%d %d",&courseid,&num);
		for(int j=0;j<num;j++){
			scanf("%s",name);
			id=getid(name);
			stu[id].pb(courseid);
		}	
	}
	char tmp[5];
	for(int i=0;i<n;i++){
		scanf("%s",tmp);
		id=getid(tmp);
        sort(stu[id].begin(),stu[id].end());
		printf("%s %d",tmp,stu[id].size()); 
		for(int j=0;j<stu[id].size();j++){
			printf(" %d",stu[id][j]);
		}
		printf("\n");
	}
	return 0;		
}

思路2:

#include<vector>
#include<string>
#include<algorithm>
#include<iostream>
#include<iterator>
#include<unordered_map>
using namespace std;
int main()
{
	int N, K;
	cin >> N >> K;
	unordered_map<string, vector<int>> hash;
	for (int i = 0; i < K; i++) {
		int classindex, student;
		cin >> classindex >> student;
		string input;
		for (int i = 0; i < student; i++) {
			cin >> input;
			auto it = hash.find(input);
			if (it == hash.end())
				hash[input] = vector<int>{ classindex };
			else
				hash[input].push_back(classindex);
		}
	}
	string query;
	for (int i = 0; i < N; i++) {
		cin >> query;
		auto& data = hash[query];
		cout << query << " " << data.size();
		sort(data.begin(), data.end());
		for (auto x : data)
			cout << " " << x;
		cout << endl;
	}
}

 

1047 Student List for Course (25分)

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤40,000), the total number of students, and K (≤2,500), the total number of courses.

Then N lines follow, each contains a student's name (3 capital English letters plus a one-digit number), a positive number C (≤20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students' names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

题意:跟上面那个题刚好反着,给定N个学生,K门课,每个学生的选课名单,求每门课的选课学生名单;

思路:vector<string> course[maxn] ; 

#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<string>
#include<cstring>
#include<vector>
#include<map>
#include<cmath>
#define pb push_back 
using namespace std;
const int maxn=2505;
vector<string> course[maxn];

int main(){
	int n,k;
	cin>>n>>k;
	string name;int num,cid;
	for(int i=0;i<n;i++){
		cin>>name>>num;
		for(int j=0;j<num;j++){
			cin>>cid;
			course[cid].pb(name);
		}	
	}
	for(int i=1;i<=k;i++){
		cout<<i<<" "<<course[i].size()<<'\n';
		sort(course[i].begin(),course[i].end());
		for(int j=0;j<course[i].size();j++){
			cout<<course[i][j]<<'\n';
		}
	}
	return 0;		
}

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值