HDU-1576 A/B

要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。
Input
数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。
Output
对应每组数据输出(A/B)%9973。

Sample Input
2
1000 53
87 123456789
Sample Output
7922
6060

ps:数论题,今天师哥刚讲了乘法逆元,然后我就A掉了,but,好像还有两种方法。。。
(我就只给一种了 啊,还有用exgcd的。。。)

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<map>
#include<vector>
#include<stdlib.h>
#include<cstring>
#include<string.h>
#include<math.h>
using namespace std ;
typedef long long ll;
#define MAX 10005
#define INF 0x3f3f3f3f//将近int类型最大数的一半,而且乘2不会爆int

ll ksm(ll a, ll b)//快速幂取模
{
    ll ans = 1;
    while(b)
    {
        if(b&1)
            ans = ans*a%9973;
        a = a*a%9973;
        b >>= 1;
    }
    return ans%9973;
}

int main()
{
    int t;
    cin >> t;
    for(int l=0; l<t; ++l)
    {
        ll n, b, s;
        cin >> n >> b;
        s = ksm(b, 9971);
        cout << n*s%9973 << '\n';
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值