I - Tree Recovery POJ - 2255

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:

                                               D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!

Input
The input will contain one or more test cases.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.

Output
For each test case, recover Valentine’s binary tree and print one line containing the tree’s postorder traversal (left subtree, right subtree, root).
Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB



题意:给出了二叉树的先序遍历和中序遍历,,求该二叉树的后序遍历。
刚写了一篇二叉树的简单操作,看完就差不多了吧!:二叉树的简单操作(递归)


//#include<bits/stdc++.h>
#include<stdio.h>
#include<iostream>
#include<string>
#include<cstring>
#include<math.h>
#include<string.h>
using namespace std ;
typedef long long ll;
#define MAXN 100005
#define INF 0x3f3f3f3f
#define MALL (endtree *)malloc(sizeof(endtree));

typedef struct endtree
{
    char ch;
    struct endtree *left, *right;
}*Node;

Node creat(char *first, char *buffer, int len)
{
    if(len < 1)
        return 0;
    Node head = MALL;
    head->ch = *first;
    char *p;
    for(p = buffer; p!=NULL; ++p)
        if(*p == *first)
            break;
    int k = p-buffer;
    head->left = creat(first+1, buffer, k);//递归还原左子树
    head->right = creat(first+k+1, p+1, len-k-1);//还原右子树
    return head;
}

void print(Node head)//后序输出二叉树
{
    if(head == NULL)
        return ;
    print(head->left);
    print(head->right);
    cout << head->ch;
}

int main()
{
    char first[55], buffer[55];
    Node head;
    head = MALL;
    while(~scanf("%s%s", first, buffer))
    {
        int len = strlen(first);
        head = creat(first, buffer, len);
        print(head);
        cout << '\n';
    }
    return 0;
}

看了别人的博客后,,发现了一个更简单的代码,用数组存的。。。。下面我摘过来了
(据说的白皮书上的。。。。。)

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
char s1[30];
char s2[30];
char s3[30];
using namespace std;
void build(int n,char *s1,char *s2,char *s)
{
    if(n<=0) return;
    int p=strchr(s2,s1[0])-s2;
    build(p,s1+1,s2,s);
    build(n-p-1,s1+p+1,s2+p+1,s+p);
    s[n-1]=s1[0];
}
int main()
{
    while(scanf("%s %s",s1,s2)==2)
    {
        int n=strlen(s1);
        build(n,s1,s2,s3);
        s3[n]='\0';
        printf("%s\n",s3);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值