J - Knuth-Morris-Pratt Algorithm

In computer science, the Knuth-Morris-Pratt string searching algorithm (or KMP algorithm) searches for occurrences of a “word” W within a main “text string” S by employing the observation that when a mismatch occurs, the word itself embodies sufficient information to determine where the next match could begin, thus bypassing re-examination of previously matched characters.

Edward is a fan of mathematics. He just learnt the Knuth-Morris-Pratt algorithm and decides to give the following problem a try:

Find the total number of occurrence of the strings “cat” and “dog” in a given string s.

As Edward is not familiar with the KMP algorithm, he turns to you for help. Can you help Edward to solve this problem?
Input
There are multiple test cases. The first line of input contains an integer T (1 ≤ T ≤ 30), indicating the number of test cases. For each test case:
The first line contains a string s (1 ≤ |s| ≤ 1000).

Output
For each case, you should output one integer, indicating the total number of occurrence of “cat” and “dog” in the string.
Sample Input
7
catcatcatdogggy
docadosfascat
dogdddcat
catcatcatcatccat
dogdogdogddddooog
dcoagtcat
doogdog

Sample Output
4
1
2
5
3
1
1

Hint
For the first test case, there are 3 “cat” and 1 “dog” in the string, so the answer is 4.
For the second test case, there is only 1 “cat” and no “dog” in the string, so the answer is 1.






题意:
在主串中查找dog和cat,,,,本来想老老实实打KMP算法的,但是发现,,,30x30x1000 = 5x10^5,呦呦呦,,,,BF可以哦,,,但是我还是用了C++中的string.find(); 然后还get到了一些string的东西,,,
比如str.npos…这种神奇的数值。。。

何为string.npos

size_t的最大值 npos是一个静态成员常量值,其值为size_t类型的元素的最大可能值。 这个值用作字符串成员函数中len(或sublen)参数的值时,意思是“直到字符串结束”。 作为返回值,通常用于表示不匹配。 此常量的值为-1,这是因为size_t是无符号整型,它是此类型最大的可表示值。

其值为:4294967295

string 类提供了 6 种查找函数,每种函数以不同形式的 find 命名。这些操作全都返回 string::size_type 类型的值,以下标形式标记查找匹配所发生的位置;或者返回一个名为 string::npos 的特殊值,说明查找没有匹配。string 类将 npos 定义为保证大于任何有效下标的值。

好了,摘了这么多,,下面我们开始愉快查找吧!

//#include<bits/stdc++.h>
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<stack>
#include<queue>			
using namespace std ;
typedef long long ll;
#define MAXN 501
#define INF 0x3f3f3f3f
#define MALL (BiTnode *)malloc(sizeof(BiTnode));

int main()
{
    int t;
    cin >> t;
    while(t--)
    {
       string s;
       cin >> s;
       int sum=0;
       int x = s.find("dog", 0);
       int y = s.find("cat", 0);
        while(x!=s.npos || y!=s.npos)
        {
            if(x!=s.npos)
            {
                sum++;
                x = s.find("dog", x+1);
            }
            if(y!=s.npos)
            {
                sum++;
                y = s.find("cat", y+1);
            }
        }
       cout << sum << '\n';
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值
>