L2-011 玩转二叉树 (递归建树)(25 分)

L2-011 玩转二叉树 (25 分)

给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
1 2 3 4 5 6 7
4 1 3 2 6 5 7

输出样例:

4 6 1 7 5 3 2

题解

递归建树…

代码
#include <bits/stdc++.h>
using namespace std;
struct BinTree
{
    int val;
    BinTree *left, *right;
    BinTree(int v)
    {
        val = v;
        left = right = nullptr;
    }
};
vector<int> in;
vector<int> pre;
BinTree* BuildTree(BinTree *root, int inl, int inr, int pl, int pr)
{
    if(inl > inr || pl > pr)
        return nullptr;
    root = new BinTree(pre[pl]);
    int mid = -1;
    for(int i=inl; i<=inr; i++)
    {
        if(in[i] == pre[pl])
        {
            mid = i;
            break;
        }
    }
    int nleft = mid - inl;
    int pl2 = pl + nleft + 1;
    root->left = BuildTree(root->left, inl, mid-1, pl+1, pl2-1);
    root->right = BuildTree(root->right, mid+1, inr, pl2, pr);
    return root;
}

BinTree* mirror(BinTree *root)
{
    if(root == nullptr)
        return root;
    root->right = mirror(root->right);
    root->left = mirror(root->left);
    BinTree *tmp = root->left;
    root->left = root->right;
    root->right = tmp;
    return root;
}

void layer_order(BinTree *root)
{
    if(root == nullptr)
        return ;
    queue<BinTree*> q;
    q.push(root);
    vector<int> ans;
    while(!q.empty())
    {
        BinTree *node = q.front();q.pop();
        ans.push_back(node->val);
        if(node->left != nullptr)
            q.push(node->left);
        if(node->right != nullptr)
            q.push(node->right); 
    }
    for(size_t i=0;i<ans.size();i++)
    {
        if(i!=0)
            cout << " ";
        cout << ans[i];
    }
}
int main()
{
    int n;
    cin >> n;
    in.resize(n);
    pre.resize(n);
    for(int i=0;i<n;i++)
        cin >> in[i];
    for(int i=0;i<n;i++)
        cin >> pre[i];
    BinTree *root=nullptr;
    root = BuildTree(root, 0, n-1, 0, n-1);
    root = mirror(root);
    layer_order(root);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值