GZHU18级寒假训练:Libra's Trial-H

HDU 1015(DFS,多重循环)

=== Op tech briefing, 2002/11/02 06:42 CST ===

  • “The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein’s secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, …, Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary.”

  • v - w^2 + x^3 - y^4 + z^5 = target

  • “For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn’t exist then.”

=== Op tech directive, computer division, 2002/11/02 12:30 CST ===

“Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or ‘no solution’ if there is no correct combination. Use the exact format shown below.”

  • Input
    1 ABCDEFGHIJKL
    11700519 ZAYEXIWOVU
    3072997 SOUGHT
    1234567 THEQUICKFROG
    0 END
  • Output
    LKEBA
    YOXUZ
    GHOST
    no solution
  • Sample Input
    1 ABCDEFGHIJKL
    11700519 ZAYEXIWOVU
    3072997 SOUGHT
    1234567 THEQUICKFROG
    0 END
  • Sample Output
    LKEBA
    YOXUZ
    GHOST
    no solution

网上看到这题因为数据小可以直接偷懒用循环。。。但题目意思是让你用DFS。所以我找了两种方法的。


五重循环
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <ctime>
#include <set>
#include <map>
#include <cmath>
using namespace std;
const int maxn = 1001;
int ta, m, len,vis[maxn],num[maxn];
char s[maxn],ch[maxn],m_ch[maxn];
map<char,int>mm;
void fun(){
    char c = 'A';
    for(int i=1;i<=26;i++)
        mm[c++] = i;
}
int is(int v,int w,int x,int y,int z,int tar){
    if(v - w*w + x*x*x - y*y*y*y + z*z*z*z*z == tar) return 1;
    else return 0;
}
void sear(){
    for(int a=0; a<len; a++){
        for(int b=0; b<len; b++){
            if(a==b) continue;
            for(int c=0; c<len; c++){
                if(c==b)continue;
                for(int d=0; d<len;d++){
                    if(c==d)continue;
                    for(int e=0; e<len; e++){
                        if( is(mm[s[a]],mm[s[b]],mm[s[c]],mm[s[d]],mm[s[e]],ta)){
                            ch[0] = s[a],ch[1] = s[b];
                            ch[2] = s[c],ch[3] = s[d];
                            ch[4] = s[e],ch[5] = '\0';
                            if(strcmp(ch,m_ch)>0) strcpy(m_ch,ch);
                        }
                    }
                }
            }
        }
    }
}
int main(){
    fun();
    while(~scanf("%d %s",&ta,s)&&(ta||strcmp(s,"END"))){
        memset(ch,'\0',sizeof(ch));
        memset(m_ch,'\0',sizeof(m_ch));
        len = strlen(s);
        sort(s,s+len);
        sear();
        if(strlen(m_ch)==0) printf("no solution\n");
        else printf("%s\n",m_ch);
    }
    return 0;
}



DFS
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <ctime>
#include <set>
#include <map>
#include <cmath>
using namespace std;
#define eps 1e-6
#define pi 3.14159265359
typedef long long LL;
const int maxn = 1001;
int ta, m, len;
int vis[maxn],num[maxn];
char s[maxn],ch[maxn],m_ch[maxn];
map<char,int>mm;
void fun(){
    char c = 'A';
    for(int i=1;i<=26;i++){
        mm[c++] = i;    
    }
} 
int is(int v,int w,int x,int y,int z,int tar){
    if(v - w*w + x*x*x - y*y*y*y + z*z*z*z*z == tar) return 1;  
    else return 0; 
}

void dfs(int cur){
    if(cur==5){
        if( is(num[0],num[1],num[2],num[3],num[4],ta) && strcmp(ch,m_ch)>0 ){
            strcpy(m_ch,ch);
        }
    }else{
        for(int i=0;i<len;i++){
            if(vis[mm[s[i]]]==0){
                num[cur] = mm[s[i]];//储存字符s[i]表示的数字
                ch[cur] = s[i];//储存字符s[i]
                vis[mm[s[i]]] = 1;//标记用过
                dfs(cur+1);
                vis[mm[s[i]]] = 0;
            }
        }
    }
}
int main(){
    fun();//打表
    //WA
    //1234567 THEQUICKFROG
    //KIUUQ(不能出现两次)
    while(~scanf("%d %s",&ta,s) && (ta||strcmp(s,"END"))){
        memset(vis,0,sizeof(vis));
        memset(ch,'\0',sizeof(ch));
        memset(m_ch,'\0',sizeof(m_ch));
        memset(num,0,sizeof(num));
        len = strlen(s);
        sort(s,s+len);//升序排列
        dfs(0);
        if(strlen(m_ch)==0) printf("no solution\n");
        else printf("%s\n",m_ch);
    }
    return 0;
}
/*
1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END
*/

来源:https://blog.csdn.net/no_alternantive/article/details/51896861

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值