PAT甲级1046 Shortest Distance

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,105​​ ]), followed by N integer distances D1​​ D2​​ ⋯ DN​​ , where Di​​ is the distance between the i-th and the (i+1)-st exits, and DN​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104​​ ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

题目大意

就是给一条循环的路,路上有若干出口,给两个出口a,b,求是从a顺时针到b路径最短还是逆时针更短。

思路

刚开始想复杂了,还想对每个点用单源最短路径的方法求到其他点的最短距离…其实很简单,充分利用循环这一条件。我列一个数组sum,记录从点1到当前点总共的距离,就比如题目给的样例

          1
     9 /      \ 1
      5        2
    14 \      / 2
        4 ——3
          4
数组sum[6] = {0, 1, 3, 7, 21, 30}
110,到21,到33,到47,到521

这样做的好处就是可以直接通过相减得到两个点之间的距离,比如我要求2到3的距离,可以直接用sum[2] - sum[1](不是sum[3] - sum[2]是因为数组从0开始)。再用一个变量total记录整个环总共的长度,样例中是30。我要求i到j最短的距离,就只要比较sum[j - 1] - sum[i - 1]和total - (sum[j - 1] - sum[i - 1])谁更短即可。
注意:sum[j - 1] - sum[i - 1]要取绝对值,比如样例中最后一个4 1,用sum[0] - sum[3]会出现负数

#include <iostream>
#include <cstdlib>
#include <vector>
#include <cmath>
using namespace std;
int main()
{
	int n, total = 0;
	cin >> n;
	vector<int> sum(n + 1);
	sum[0] = 0;
	for (int i = 1; i <= n; i++)
	{
		int num;
		cin >> num;
		total += num;
		sum[i] = total;
	}
	int k;
	cin >> k;
	for (int i = 0; i < k; i++)
	{
		int b,e;
		cin >> b >> e;
		int short_dis = (abs(sum[e - 1] - sum[b - 1]) < abs(total - abs(sum[e - 1] - sum[b - 1])) ? abs(sum[e - 1] - sum[b - 1]) : abs(total - abs(sum[e - 1] - sum[b - 1])));
		cout << short_dis << endl;
	}
	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L). To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river. Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ M ≤ N). FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks. Input Line 1: Three space-separated integers: L, N, and M Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position. Output Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks Sample Inputcopy Outputcopy 25 5 2 2 14 11 21 17 4 Hint Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).
最新发布
07-24

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值