PAT甲级1096 Consecutive Factors//质因子分解

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231​​ ).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
567

题目大意

求一段连续的正数,能让输入的n被这段连续整数的乘积整除。注意you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.如果有多个方案,输出连续整数个数最多的那个方案;如果还有多个方案,输出第一个数最小的方案。

思路

其实只要在2~√n之间找这串连续的数就行了,因为大于√n的连续整数相乘肯定大于n。然后同时记录这串数字的长度和开头数字即可。遇到长度更长的就更改两个变量。注意如果题目给的是一个质数,最后要输出1和这个数本身。

#include <iostream>
#include <cstdlib>
#include <vector>
using namespace std;
int main()
{
	long long n;
	cin >> n;
	long long ans_start = 0, ans_len = 0;
	for (long long i = 2; i * i <= n; i++)
	{
		long long j = i, ans = 1;
		while (1)
		{
			ans *= j;
			if (n % ans != 0)
				break;
			if (j - i + 1 > ans_len)
			{
				ans_start = i;
				ans_len = j - i + 1;
			}
			j++;
		}
	}
	if (ans_len == 0)
	{
		cout << 1 << endl;
		cout << n << endl;
	}
	else
	{
		cout << ans_len << endl;
		for (long long i = 0; i < ans_len; i++)
		{
			if (i > 0)
				cout << "*";
			cout << ans_start;
			ans_start++;
		}
	}
	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值