PAT甲级1145 Hashing - Average Search Time//散列表平方探测法解决冲突

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.
Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 104 . Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 105 .

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

思路

先建散列表然后将数据插入,每次插入如果那个位置已有数据或者一直找不到位置插入则显示该数字cannot be inserted。搜索的时候每次搜索到一个位置次数加1,如果这个位置是该数,或者这个位置是-1(表示没有这个数)则直接退出表示找到了;如果一直到最后都没找到则搜索次数要再加1(不清楚原因)

#include <iostream>
#include <cstdlib>
#include <vector>
#include <iomanip>
using namespace std;
int Tsize, N, M;
bool isPrime(int);
int Hash(int n) { return n % Tsize; }
int main()
{
	cin >> Tsize >> N >> M;
	while (!isPrime(Tsize))
		Tsize++;
	vector<int> vec(Tsize, -1);
	for (int i = 0; i < N; i++)
	{
		int num, flag = 0;
		cin >> num;
		for (int j = 0; j < Tsize; j++)
		{
			int pos = (Hash(num) + j * j) % Tsize;
			if (vec[pos] == -1)
			{
				vec[pos] = num;
				flag = 1;
				break;
			}
		}
		if (!flag)
			cout << num << " cannot be inserted." << endl;
	}
	int total = 0;
	for (int i = 0; i < M; i++)
	{
		int num;
		cin >> num;
		bool found = false;
		for (int j = 0; j < Tsize; j++)
		{
			total++;
			int pos = (Hash(num) + j * j) % Tsize;
			if (vec[pos] == num || vec[pos] == -1)
			{
				found = true;
				break;
			}
		}
		if (!found)
			total++;
	}
	cout << fixed << setprecision(1) << total * 1.0 / M << endl;
	system("pause");
	return 0;
}
bool isPrime(int n)
{
	if (n < 2)
		return false;
	for (int i = 2; i * i <= n; i++)
		if (n % i == 0)
			return false;
	return true;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值