codeup|问题 E: Shortest Distance (20)

这篇博客主要讨论了一个算法问题,即如何在给定的高速公路环形出口网络中,快速计算任意两个出口之间的最短距离。作者提供了一个优化的解决方案,通过预计算每个出口到起点的距离数组`dis`,避免了在寻找最短路径时进行多次循环计算,从而提高了时间效率。示例输入和输出展示了算法的正确性和效率。
摘要由CSDN通过智能技术生成

题目描述
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
输入
Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.
输出
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
样例输入 Copy
5 1 2 4 14 9
3
1 3
2 5
4 1
样例输出 Copy
3
10
7

代码

#include<stdio.h>
#include<algorithm>

int main() {
    int a[100001], dis[100001];
    int n, m, b, c;
    int sum = 0;
    scanf("%d", &n);
    for (int i = 1; i <= n; i++) {
        dis[i] = sum;//dis标识顺时针第i个节点到第1个节点的距离
        scanf("%d", &a[i]);
        sum += a[i];
    }
    scanf("%d", &m);
    while (m--) {
        scanf("%d %d", &b, &c);
        if (b > c) std::swap(b, c);
        int len = dis[c] - dis[b];
        int len1 = sum - len;
        if (len < len1) { printf("%d\n", len); }
        else printf("%d\n", len1);

    }

    return 0;
}

由于需要考虑时间效率因此引入dis数组。如果直接使用如下代码可能会超过时间限制:

#include<stdio.h>

int main() {
    int n, m, b, c;
    int sum = 0;
    int a[100000] = {0};
    scanf("%d", &n);
    for (int i = 1; i <= n; i++) {
        scanf("%d", &a[i]);
        sum += a[i];
    }
    scanf("%d", &m);
    while (m--) {
        int len = 0;
        scanf("%d %d", &b, &c);
        if (b > c) {
            int temp = b;
            b = c;
            c = temp;
        }
        for (int i = b; i < c; i++) {
            len += a[i];
        }
        if (len < sum - len) printf("%d\n", len);
        else printf("%d\n", sum - len);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值