算法笔记Codeup 问题 E: Shortest Distance (20)

题目描述

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
输入

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.
输出

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
样例输入 Copy

5 1 2 4 14 9
3
1 3
2 5
4 1
样例输出 Copy

3
10
7

翻译:第一行先给出有N个结点,围成一个圈,后给出这N个结点间的距离,最后一个数表示最后一个结点和第一个结点的距离;
第二行给出有M对结点,后M行给出这M对结点的位置,要求依次输出这M对结点间的最短距离。(也就是对比顺时针和逆时针距离大小)
思路:先把这N段距离存入dis数组,后计算顺时针和逆时针的距离,输出较小者。

#include<stdio.h>
#include<string.h>
int main(){
    int n,m,l,r;
    scanf("%d",&n);
    int dis[n];
    for(int i=0;i<n;i++){
        scanf("%d",&dis[i]);//把距离存入数组
    }
    scanf("%d",&m);
    for(int i=0;i<m;i++){
        scanf("%d%d",&l,&r);
        if(l>r){    //4到1和1到4是一样的,统一化处理
            int p=r;
            r=l;
            l=p;
        }
        int cw=0,acw=0;  //clockwise,anti-clockwise
        for(int j=l-1;j<r-1;j++){  //顺时针一段
            cw+=dis[j];
        }
        for(int j=0;j<l-1;j++){		//逆时针两段
            acw+=dis[j];
        }
        for(int j=r-1;j<n;j++){
            acw+=dis[j];
        }
        if(cw<acw) printf("%d\n",cw);//输出较小数
        else printf("%d\n",acw);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值