HDU5115-Dire Wolf(区间DP)

Dire wolves, also known as Dark wolves, are extraordinarily large and powerful wolves. Many, if not all, Dire Wolves appear to originate from Draenor.
Dire wolves look like normal wolves, but these creatures are of nearly twice the size. These powerful beasts, 8 - 9 feet long and weighing 600 - 800 pounds, are the most well-known orc mounts. As tall as a man, these great wolves have long tusked jaws that look like they could snap an iron bar. They have burning red eyes. Dire wolves are mottled gray or black in color. Dire wolves thrive in the northern regions of Kalimdor and in Mulgore.
Dire wolves are efficient pack hunters that kill anything they catch. They prefer to attack in packs, surrounding and flanking a foe when they can.
— Wowpedia, Your wiki guide to the World of Warcra

Matt, an adventurer from the Eastern Kingdoms, meets a pack of dire wolves. There are N wolves standing in a row (numbered with 1 to N from left to right). Matt has to defeat all of them to survive.

Once Matt defeats a dire wolf, he will take some damage which is equal to the wolf’s current attack. As gregarious beasts, each dire wolf i can increase its adjacent wolves’ attack by b i. Thus, each dire wolf i’s current attack consists of two parts, its basic attack ai and the extra attack provided by the current adjacent wolves. The increase of attack is temporary. Once a wolf is defeated, its adjacent wolves will no longer get extra attack from it. However, these two wolves (if exist) will become adjacent to each other now.

For example, suppose there are 3 dire wolves standing in a row, whose basic attacks ai are (3, 5, 7), respectively. The extra attacks b i they can provide are (8, 2, 0). Thus, the current attacks of them are (5, 13, 9). If Matt defeats the second wolf first, he will get 13 points of damage and the alive wolves’ current attacks become (3, 15).

As an alert and resourceful adventurer, Matt can decide the order of the dire wolves he defeats. Therefore, he wants to know the least damage he has to take to defeat all the wolves.
Input
The first line contains only one integer T , which indicates the number of test cases. For each test case, the first line contains only one integer N (2 ≤ N ≤ 200).

The second line contains N integers a i (0 ≤ a i ≤ 100000), denoting the basic attack of each dire wolf.

The third line contains N integers b i (0 ≤ b i ≤ 50000), denoting the extra attack each dire wolf can provide.
Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the least damage Matt needs to take.
Sample Input
2
3
3 5 7
8 2 0
10
1 3 5 7 9 2 4 6 8 10
9 4 1 2 1 2 1 4 5 1
Sample Output
Case #1: 17
Case #2: 74

分析:

题意:
由n只狼,我们要将它们都杀死,杀每只狼我们都会遭受到狼的反抗,对我们造成伤害。由于狼是群居动物,我们在杀某只狼时,不但会受到该狼的伤害,还会被其相邻的两只狼带来附加伤害!我们要把所有的狼都杀死所受到的最低伤害是多少?当一只狼被杀死了之后他就不是原来的狼的邻居了!
输入第一行是一个输入n,表示狼的数量,然后就是两行输入每行n个数,第一行是狼自生的伤害,第二行是每只狼对相邻的狼伤害的加成!

解析:
我们首先清楚的是,无论每只狼的邻居都i是哪些狼,我们都会遭到固定的伤害,即所有的狼固定伤害的总和sum!

然后我们就选择其中的一些狼来杀掉,这样就改变了狼的邻居的附加伤害!所以我们要求的就是选择某些狼来杀掉,让造成附加伤害降到最低!我们用数组dp[i][j]来表示杀掉区间i~j所有的狼造成的最低伤害,到这里都还挺简单的!但是dp[i][j]要怎么求解呢?

这里我们设i~j的区间里最后还剩下一只狼K,那么我们杀死他受到的附加伤害是:
book[i-1]+book[j+1];
所以我们求解的dp[i][j]的值就是:
dp[i][j]=min(dp[i][j],dp[i][k-1]+dp[k+1][j]+book[i-1]+book[j+1];

所以最后的结果就是dp[1][n]+sum;

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#define INF 0x3f3f3f3f
#define N 205

using namespace std;

int book[N];
int dp[N][N];

int main()
{
	int T,n;
	scanf("%d",&T);
	for(int t=1;t<=T;t++)
	{
		int sum=0,val;
		memset(dp,0,sizeof(dp));
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&val);
			sum+=val;
		}
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&book[i]);
			for(int j=i;j<=n;j++)
			{
				dp[i][j]=INF;
			}
		}
		book[0]=book[n+1]=0;
		for(int len=1;len<=n;len++)
		{
			for(int i=1;i+len-1<=n;i++)
			{
				int j=i+len-1;
				for(int k=i;k<=j;k++)
				{
					dp[i][j]=min(dp[i][j],dp[i][k-1]+dp[k+1][j]+book[i-1]+book[j+1]);
				}
			}
		}
		printf("Case #%d: %d\n",t,sum+dp[1][n]);
	}
	return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值