1069 The Black Hole of Numbers (20 分)

1069 The Black Hole of Numbers (20 分)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …
Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:
Each input file contains one test case which gives a positive integer N in the range (0,10​4).

Output Specification:
If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:
6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input 2:
2222
Sample Output 2:
2222 - 2222 = 0000

AC代码

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main() {
	int Num[11] = { 0 };
	int N;
	cin >> N;
	int n = N;
	int flag = 0;
	if (N / 1000 == 0) {
		if (N / 100 == 0) {
			if (N / 10 == 0) Num[0] = 3;
			else Num[0] = 2;
		}
		else Num[0] = 1;
	}	//将不足四位的数补齐
	while (N > 0) {
		Num[N % 10]++;
		N /= 10;
	}	//将数字存入数组
	for (int i = 0; i < 10; i++) {
		if (Num[i] == 4) {
			printf("%d - %d = 0000\n", n, n);
			return 0;
		}
	}	//如果四位数字均相同
	int ret;
	while (!flag) {
		int Big = 0, Small = 0;
		for (int i = 9; i >= 0; i--) {
			for (int j = 0; j < Num[i]; j++)
				Big = Big * 10 + i;
		}	//将存入数组的数字从大到小组成大数
		for (int i = 1; i < 10; i++) {
			for (int j = 0; j < Num[i]; j++)
				Small = Small * 10 + i;
		}	//将存入数组的数字从小到大组成小数
		ret = Big - Small;	//计算大减小的结果
		printf("%04d - %04d = %04d\n", Big, Small, ret);
		if (ret == 6174) flag = 1;	//到达数字黑洞
		else {
			for (int i = 0; i < 10; i++) Num[i] = 0;	//数组清零
			if (ret / 1000 == 0) {
				if (ret / 100 == 0) {
					if (ret / 10 == 0) Num[0] = 3;
					else Num[0] = 2;
				}
				else Num[0] = 1;
			}	//将结果不足四位的补齐
			while (ret > 0) {
				Num[ret % 10]++;
				ret /= 10;
			}	//将结果存入数组继续循环
		}
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值