1069 The Black Hole of Numbers (20分)【数学问题】

1069 The Black Hole of Numbers (20分)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4​​).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

解题思路:

这道题目其实很好理解,我们写一个函数将输入的数的各个位的数重新排列,然后返回其最大和最小的数。

#include<iostream>
#include<algorithm>
using namespace std;

int cmp(int a, int b)   //递减排序
{
	return a > b;
}

void fun(int num, int &max, int &min)
{
	int arr[5];
	for (int i = 0; i < 4; i++)
	{
		arr[i] = num % 10;
		num /= 10;
	}
	sort(arr, arr + 4, cmp);
	for (int i = 0; i < 4; i++)
	{
		max = max * 10;
		max += arr[i];
	}
	for (int i = 3; i >=0; i--)
	{
		min = min * 10;
		min += arr[i];
	}
}

int main()
{
	int num;
	cin >> num;
	int ans = -1;
	while (ans != 6174)
	{
		int max = 0, min = 0;
		fun(num, max, min);
		ans = max - min;
		printf("%04d - %04d = %04d\n", max, min, ans);
		num = ans;
		if (ans == 0)
			break;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值