Power Strings【KMP循环节】

Given two strings a and b we define ab to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
解题思路:
典型的kmp求循环节题目。判断n%(n-f[n])是否等于0,如果等于零说明这个字符串是由多个相同字符串组成的,n/(n-f[n])就是所求答案。
代码

#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;
const int N = 1000005;
char s[N];
int f[N];
int len;
void getfail(){
    f[0]=0,f[1]=0;
    int j;
    for(int i=1;i<len;i++){
        j=f[i];
        while(j&&s[i]!=s[j]) j=f[j];
        f[i+1]= s[i]==s[j]?j+1:0;
    }
}
int main(){
    while(~scanf("%s",s),s[0]!='.'){
        len=strlen(s);
        getfail();
        if(len%(len-f[len])==0)
            printf("%d\n",len/(len-f[len]));
        else
            printf("1\n");

    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

轩辕青山

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值