I - How many integers can you find【容斥定理】

Discription
Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

Input
There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.

Output
For each case, output the number.

Sample Input
12 2
2 3

Sample Output
7

题意:
给定一个n和m个不同的数,求小于n的数中能整除这m个数中任意一个或多个的数额个数。

思路
根据题意可以知道,所有成立的数的总和就是:能整除一个数的个数减去能整除两个数的个数,加上能整除三个数的个数。
即,结果=每个数的倍数的个数-两个数最小公倍数的个数和+三个数最小公倍数和-…一直到第n个数
这很明显是个容斥定理,还不太会写。

AC代码

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
LL gcd(LL a, LL b)
{
    return b?gcd(b,a%b):a;
}//最大公约数
LL lcm(LL a,LL b)
{
    return (a*b)/gcd(a,b);
}//最小公倍数
int vis[30];
long long n,sum;
int m,k;
int a[20];
void dfs(int x/*第一个数的位置*/,int ans/*几个数d*/,int num/*目前已经有几个数*/)
{
    if(ans==num)
    {
        int xxx=1;
        for(int i=1; i<=k; i++)
            if(vis[i])
                xxx=lcm(xxx,a[i]);//几个数的最小公倍数
        if(ans&1)
            sum+=(n-1)/xxx;
        else
            sum-=(n-1)/xxx;
        return ;
    }
    for(;x<=k; x++)
        if(!vis[x])
        {
            vis[x]=1;
            dfs(x+1,ans,num+1);
            vis[x]=0;
        }
}

int main()
{
    while(scanf("%lld %d",&n,&m)!=EOF)
    {
        k=0;
        sum=0;
        for(int i=1; i<=m; i++)
        {
            int xx;
            scanf("%d",&xx);
            if(xx)
                a[++k]=xx;
        }
        for(int i=1; i<=k; i++)
        {
            memset(vis,0,sizeof(0));
            dfs(1,i,0);
        }
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值