HDU - 1796 How many integers can you find(容斥定理)

HDU - 1796 How many integers can you find(容斥定理)

Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
Input
There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
Output
For each case, output the number.
Sample Input
12 2
2 3
Sample Output
7

题目大意:

给定n 和 m 并给一个有m个数的集合。
问 小于n的 是这m个数中任意一个数的倍数的数的个数。

解题思路:

容斥定理
x1=n/a 就是<=n的a的倍数有多少个
x2=n/b 就是<=n的b的倍数有多少个
x3=n/(ab) 就是<=n的ab的倍数有多少个
x1+x2-x3就是<=n的a或者b的倍数有多少个

那么这个题就是推广到了m个数。重叠了奇数次就加 重叠了偶数次就减。
另外要注意 这m个数中可能有0导致答案错误。要判断下>0 不然会WA

AC代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#define ll long long 
using namespace std;
ll n;
int m;
ll D[20];
ll gcd(ll a,ll b){
    if(b==0) return a;
    else{
        return gcd(b,a%b);
    }
}
ll lcm(ll a,ll b){
    return a*b/gcd(a,b);
}
ll ans = 0;
int cnt = 0;
void dfs(int num,int time,ll now){//now 第几个数 time重叠了多少次 now当前的lcm

    if(time>cnt) return;
    ll lcc = lcm(D[num],now);
    if(time&1) ans += (n-1)/lcc;
    else ans -= (n-1)/lcc;
    for(int i=num+1;i<cnt;i++){
        dfs(i,time+1,lcc);
    }   
}
int main(){
    while(~scanf("%lld%d",&n,&m)){
        ans = 0;
        cnt = 0;
        for(int i=1;i<=m;i++){
        	ll tmp;
            scanf("%lld",&tmp);
            if(tmp>0){
            	D[cnt++] = tmp;
            }
        }
        for(int i=0;i<cnt;i++){
            dfs(i,1,D[i]);
        }
        cout<<ans<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值