E - How many integers can you find(容斥定理的应用)

  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

Input

  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.

Output

  For each case, output the number.

Sample Input

12 2
2 3

Sample Output

7

解析:

/*
a1 a2 a3 a4 ... an 
0  0  0  0       0   选或者不选
1  1  1  1       1

 例如:m = 3,有
 i = 0 -  i < 8;
             i
0 0 0    0 
0 0 1   1 
0 1 0   2 
0 1 1   3//
1 0 0   4
1 0 1   5
1 1 0   6
1 1 1   7

0 1 1  & 
0 0 1 
0 0 1
*/

 

代码:

#include <bits/stdc++.h>
using namespace std;
#define  ll long long
ll gcd(ll a, ll b)
{
	return b == 0 ? a : gcd(b, a % b);
}
ll lcm(ll a, ll b)
{
	return a / gcd(a, b) * b;
}

int a[100];
int main(){
	int n, m; 
	while(cin>>n>>m)
	{
		for(int i = 0; i < m; i++) 
		{
			scanf("%d", &a[i]);
			if(a[i]>=n||a[i]<1)
			{
				i--;   //a[j]大于n的要除去
				m--;   //且a[i]不能为0,因为不会有一个小于n
			}          //的数可以整除0,这是违反数学的?
		}
		n-=1;
	    ll ans = 0; //从“1”开始循环,因为“0”什么也不选,对本题无意义 
    	for(int i = 1; i < (1 << m); i++)
		{            //相当于枚举所有的情况 o(2^n*n)  
		   int  cnt = 0;//选还是不选有两种情况,1 << m等价于2的m次方 
		   ll tmp = 1;
		   for(int j = 0; j < m ;j++)
		   {    
			  if(i >> j & 1) 
			  {
				cnt ++;//统计每一行 1 (即选) 的数目,"奇加偶减" 
				tmp = lcm(tmp, a[j]); 
			  }
			  //cout<<(i >> j & 1);打印二进制码 
		   }	
		if(cnt & 1) ans += n/tmp;
		else ans -= n / tmp; 
	   }
	printf("%lld\n", ans); 
	}
	
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值