【团体天梯赛/PTA】7-46 Have Fun with Numbers (20 分)

【团体天梯赛/PTA】7-46 Have Fun with Numbers (20 分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

题目大意:

给出一个不超过20位的正整数,如果构成它的数字1-9也可以构成它的两倍(即通过重排列,是一个数可以组成它的两倍),则输出Yes和它的两倍的数值,反之输出No和它的两倍的数值。

解题思路:

  1. 给出的最大数值为20位数值,超出long long 的范围,故使用字符数组记录。
  2. 使用string类型记录,便于输入与处理长度
  3. 创建一个长度为10的整型数组,输入数值时,使对应下标+1,输出*2数值使,使对应下标-1.
  4. 最后判断,如果整型数组全为0,则输出Yes,反之输出No
#include<iostream>
#include<string>
using namespace std;
string Input;//输出的数
string Output;//输出的数
int pre=0, relax; //pre为进位,relax为余数
int Judge[10] = { 0 };//判断数组,全为0则happy,反之不happy
int main() {
	cin >> Input;
	for (int i = 0; i < Input.size(); ++i) //遍历输入,改变Judge
	{
		Judge[int(Input[i] - '0')]++; //对应下标数组+1
	}
	for (int i = Input.size() - 1; i >= 0; --i) //倒序遍历输入,计算结果
	{
		relax = (int(Input[i] - '0') * 2+pre) % 10;//计算余数
		Output += char(relax+'0');
		pre = int(Input[i] - '0') * 2 / 10;//计算进位
		if (i == 0 && pre != 0) Output += char(pre+'0'); //最后一位进位拓展
	}
	for (int i = 0; i < Output.size(); ++i) //遍历输出,改变Judge
	{
		Judge[int(Output[i] - '0')]--;
	}
	for (int i = 0; i < 10; ++i)//遍历Judge,判断
	{
		if (Judge[i] != 0) //存在不为0,则不happy
		{
			cout << "No" << endl;
			for (int i = Output.size() - 1; i >= 0; --i)
			{
				cout << Output[i];
			}
			return 0;
		}
		else continue;
	}
	cout << "Yes" << endl;
	for (int i = Output.size() - 1; i >= 0; --i)
	{
		cout << Output[i];
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值