问题 C: Goldbach’s Conjecture
时间限制: 1 Sec 内存限制: 32 MB
提交: 337 解决: 222
题目描述
Goldbach’s Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.
A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.
输入
An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.
输出
Each output line should contain an integer number. No other characters should appear in the output.
样例输入
4
10
16
0
样例输出
1
2
2
思路
题目要求找一对数 同时一样的p1,p2不能被计数两次,解决方法是只遍历到一半,<=n/2,注意10可以被3,7以及5,5得到,说明一个数可以重复使用,然后只要判断isPrime(i)&&isPrime(n-i)即可
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
bool isPrime(int n){
if(n<=1) return false;
int sqr=(int)sqrt(1.0*n);
for(int i=2;i<=sqr;i++){
if(n%i==0)
return false;
}
return true;
}
int main(){
int n;
while(scanf("%d",&n)!=EOF){
if(n==0) break;
int sum=0;
for(int i=2;i<=n/2;i++){
if(isPrime(i)&&isPrime(n-i)) sum++;
}
printf("%d\n",sum);
}
return 0;
}