Aquarius's Trial I-9 POJ - 2253 & J - 0 POJ - 1797

 

                                                                      Frogger

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2

0 0

3 4

3

17 4

19 4

18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

思路:复制一下别人的题意,有两只青蛙和若干块石头,现在已知这些东西的坐标,两只青蛙A坐标和青蛙B坐标是第一个和第二个坐标,现在A青蛙想要到B青蛙那里去,并且A青蛙可以借助任意石头的跳跃,而从A到B有若干通路,问从A到B的所有通路上的最大边,比如有  有两条通路  1(4)5 (3)2 代表1到5之间的边为4,  5到2之间的边为3,那么该条通路跳跃范围(两块石头之间的最大距离)为 4,  另一条通路 1(6) 4(1) 2 ,该条通路的跳跃范围为6, 两条通路的跳跃范围分别是 4 ,6,我们要求的就是最小的那一个跳跃范围,即4,用三种方法都能解决

但是,我还是没懂(我好菜呀!)

#include <iostream>
#include <queue>
#include <vector>
#include <cmath>
#include <iomanip>
#include <algorithm>
#define inf 0x3f3f3f3f
#define maxn 360
using namespace std;
vector<pair<int, double > >mmp[maxn];
int x[maxn], y[maxn], n;
double dis[maxn];
int vis[maxn];
double w(int i, int j)
{
	return sqrt(double(x[i] - x[j])*(x[i] - x[j]) + double(y[i] - y[j])*(y[i] - y[j]));
}
void spfa()
{
	for (int i = 1; i <= n; i++)
		dis[i] = inf;
	queue<int >que;
	que.push(1);
	dis[1] = 0;
	vis[1] = 1;
	while (!que.empty())
	{
		int top = que.front();
		que.pop();
		vis[top] = 0;
		for (int i = 0; i < mmp[top].size(); i++)
		{
			int temp = mmp[top][i].first;
			if (dis[temp]>max(dis[top], mmp[top][i].second))
			{
				dis[temp] = max(dis[top], mmp[top][i].second);
				if (!vis[temp])
				{
					vis[temp] = 1;
					que.push(temp);
				}
			}
		}
	}
}
int main()
{
	int q = 1;
	while (cin >> n&&n)
	{
		for (int i = 1; i <= n; i++)
			cin >> x[i] >> y[i];
		for (int i = 1; i <= n; i++)
			for (int j = i + 1; j <= n; j++)
			{
				mmp[i].push_back(make_pair(j, w(i, j)));
				mmp[j].push_back(make_pair(i, w(i, j)));
			}
		spfa();
		cout << "Scenario #" << q++ << endl;
		cout << "Frog Distance = " << fixed << setprecision(3) << dis[2] << endl << endl;
		for (int i = 1; i <= n; i++)
			mmp[i].clear();
	}
}

                                                                         Heavy Transportation

Description

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1

3 3

1 2 3

1 3 4

2 3 5

Sample Output

Scenario #1:
4

实在看不懂,参考别人博客:https://blog.csdn.net/w13884794538/article/details/81258840 

题目大意:每条路上可以搭载的货物量有上限,问要走到终点,可以运载的最大载物量

解题思路:寻找每条可能行的通的路中,最小的那条边(因为一条路中的允许重量取决于最小值),再把每条路中最小的这条边中取最大的,bellman-ford和djiska和floyd都可以。(我看不懂呀!)

以下是完整代码:

#include <iostream>
#include <algorithm>
using namespace std;
int n, m;
int ma[1003][1003];
int v[1003];
int dis[1003];
void Dijkstra()
{
	for (int i = 1; i <= n; i++)
	{
		v[i] = 0;
		dis[i] = ma[1][i];
	}
	dis[1] = 0;
	v[1] = 1;
	int point, minx;
	for (int i = 1; i <= n; i++)
	{
		point = i;
		minx = -1;//初始值最小
		for (int j = 1; j <= n; j++)
		{
			if (v[j] == 0 && minx<dis[j])
			{
				point = j;
				minx = dis[j];//寻找最大的边值(承受重量最大)
			}
		}
		v[point] = 1;
		for (int j = 1; j <= n; j++)//更新
		{
			if (v[j] == 0 && dis[j]<min(ma[point][j], dis[point]))
				dis[j] = min(ma[point][j], dis[point]);
		}
	}
	cout << dis[n] << "\n\n";//输出最小的承受重量
}
int main()
{
	int t;
	cin >> t;
	int ans = 1;
	while (t--)
	{
		memset(ma, 0, sizeof(ma));
		cin >> n >> m;
		for (int i = 0; i < m; i++)
		{
			int a, b, c;
			cin >> a >> b >> c;
			ma[a][b] = ma[b][a] = c;
		}
		cout << "Scenario #" << ans << ":\n";
		ans++;
		Dijkstra();
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值