PAT-甲级-1042-Shuffling Machine(20)

题目描述

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

输入格式:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20)
which is the number of repeat times. Then the next line contains the
given order. All the numbers in a line are separated by a space.

输出格式:

For each test case, print the shuffling results in one line. All the
cards are separated by a space, and there must be no extra space at the
end of the line.

输入样例:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

输出样例:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

题目信息:

作者: CHEN, Yue

单位: 浙江大学

时间限制: 400 ms

内存限制: 64 MB

代码长度限制: 16 KB

题目大意

自动洗牌机

这台机器按照给定的随机顺序洗牌一副54张牌,并重复一定次数。假设卡片组的初始状态如下:

S1,S2,…,S13,

H1,H2,…,H13,

C1,C2,…,C13,

D1,D2,…,D13,

J1、J2

其中“S”代表“黑桃♠”,“H”代表“红桃♥”,“C”代表“梅花♣”,“D”代表“方片♦”,“J”代表“小丑(王)”。给定的顺序是[1,54]中不同整数的排列。如果第i个位置的数字是j,则意味着将卡从位置i移动到位置j。例如,假设我们只有5张卡:S3、H5、C1、D13和J2。给定洗牌顺序{4,2,5,3,1},结果将是:J2,H5,D13,S3,C1。如果我们再次重复洗牌,结果将是:C1、H5、S3、J2、D13。

每个输入文件包含一个测试用例。

第一行包含一个正整数K(≤20),它是重复次数。

下一行包含给定的顺序。一行中的所有数字都用空格隔开。

输出规格:
对于每个测试用例,在一行中打印洗牌结果。所有的卡片都被一个空格隔开,行的末尾不能有多余的空格。

分析

题目中先给定一个初始的牌序

第一行输入洗牌的次数

第二行输入洗牌的方式

举个例子,假设 初始顺序为 H1, C2, J2, D13

洗牌方式为change[2, 3, 4, 1],洗一次就是说把第一张牌放到位置1、第二张牌放到位置2、第三张牌放到位置3、第四张牌放到位置0,结果为:D13, H1, C2, J2

洗第二次就是在第一次洗完的结果上再重复上述操作

实际上,第一次洗牌之后,第一张牌会到位置change[0]、也就是位置2上

第二次洗牌后,第一张牌就到了位置change[change[0]],即位置change[2] ,也就是位置3

所以我们可以不用真的洗牌,只要这样一层一层嵌套,读取到每张牌最终位置就可以,之后把这张牌放到最终位置上

最后顺序输出

代码步骤

  1. 对于每张牌来说
    1. 首先设置本张牌第一次洗牌之后的位置pos

      • 注意可能洗0次
    2. 获取本张牌 在第一次洗牌的基础上 总次数-1 次洗牌之后的位置

      for(int j=1;j<time;j++)
          pos=change[pos];
      

代码实现-JAVA

import java.util.*;

public class Main {
    public static void main(String[] args) throws Exception{
		Scanner sc = new Scanner(System.in);
        
        // 洗牌的次数
		int time = sc.nextInt();

		// 牌的初始顺序
		String[] flower = new String[54];
		// 洗牌方式
		int[] change = new int[54];
		// 一次变化之后的位置
		int pos;
		// 牌的最终顺序
		int[] end = new int[54];
		
        // 读入洗牌方式
		for(int i = 0; i<54; i++) change[i]=sc.nextInt()-1;
        
        // 设置牌的初始顺序
		int base=-1;
		for(int i=1; i<=13; i++) flower[i+base] = "S"+i; base+=13;
		for(int i=1; i<=13; i++) flower[i+base] = "H"+i; base+=13;
		for(int i=1; i<=13; i++) flower[i+base] = "C"+i; base+=13;
		for(int i=1; i<=13; i++) flower[i+base] = "D"+i; base+=13;
		flower[52] = "J1"; flower[53]="J2";
		
		// 对每张牌(共54张)都获取最终位置
		for(int i = 0; i < 54; i++) {
            // 输入排序次数可能是0
			if(time>0)
                pos = change[i]; // 获取一次的位置
			else pos=i;
            // 获取 总次数-1 次之后的位置
			for(int j=1;j<time;j++)
                pos=change[pos];
            // 将本张牌放在最终位置上
			end[pos]=i;
		}
        // 顺序输出
		for(int i=0;i<53;i++) {
			System.out.print(flower[end[i]]+" ");
		}
        System.out.println(flower[end[53]]);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值