zoj 3543 Number String 已知排列数的增减顺序,求排列数的个数

The signature of a permutation is a string that is computed as follows: for each pair of consecutive elements of the permutation, write down the letter 'I' (increasing) if the second element is greater than the first one, otherwise write down the letter 'D' (decreasing). For example, the signature of the permutation {3,1,2,7,4,6,5} is "DIIDID".

Your task is as follows: You are given a string describing the signature of many possible permutations, find out how many permutations satisfy this signature.

Note: For any positive integer n, a permutation of n elements is a sequence of length n that contains each of the integers 1 through n exactly once.

Input

Each test case consists of a string of 1 to 1000 characters long, containing only the letters 'I', 'D' or '?', representing a permutation signature.

Each test case occupies exactly one single line, without leading or trailing spaces.

Proceed to the end of file. The '?' in these strings can be either 'I' or 'D'.

Output

For each test case, print the number of permutations satisfying the signature on a single line. In case the result is too large, print the remainder modulo 1000000007.

Sample Input
II
ID
DI
DD
?D
??
Sample Output
1
2
2
1
3
6

//

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int mod=1000000007;
const int maxn=1100;
//f[i][j]表示长度为i以j结尾的排列个数(1<=j<=i)
int f[maxn][maxn];
char str[maxn];
int main()
{
    while(scanf("%s",str)==1)
    {
        int len=strlen(str);
        int n=len+1;
        f[1][1]=1;
        for(int i=2;i<=n;i++)
        {
            char ch=str[i-2];
            if(ch=='?')//f[i][j]=sum(f[i-1][k]) 1<=k<=i-1
            {
                int sum=0;
                for(int j=1;j<=i-1;j++) sum=(sum+f[i-1][j])%mod;
                for(int j=1;j<=i;j++)
                {
                    f[i][j]=sum;
                }
            }
            else if(ch=='I')//f[i][j]=sum(f[i-1][k]) 1<=k<=j-1
            {
                f[i][1]=0;
                for(int j=2;j<=i;j++)
                {
                    f[i][j]=(f[i][j-1]+f[i-1][j-1])%mod;
                }
            }
            else//f[i][j]=sum(f[i-1][k]) j<=k<=i-1 (important j<=k)
            {
                f[i][i]=0;
                for(int j=i-1;j>=1;j--)
                {
                    f[i][j]=(f[i][j+1]+f[i-1][j])%mod;
                }
            }
        }
        int cnt=0;
        for(int i=1;i<=n;i++)
        {
            cnt=(cnt+f[n][i])%mod;
        }
        printf("%d\n",cnt);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值