Bomb HDU - 3555(经典数位dp)

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
Output
For each test case, output an integer indicating the final points of the power.
Sample Input
3
1
50
500
Sample Output
0
1
15

刚开始接触数位dp,写点东西记录一下吧。

思路:数位dp其实是一个简化普通数数字的过程,我们每次需要找出一些满足某一特性的值,那么数字本身的属性是定的,所以我们找过的状态就可以保存起来。比如我们已经找到前100中符合条件的数字有多少个,那么搜第三位,也就是百位的时候,就可以直接把前两位已经搜过的状态拿过来用。

数位dp的数组一般第一维都是位数,并且从高到低搜,枚举第len位时,往下搜的时候如果len-1位的所有状态已经搜过,那么直接加上dp[len-1]即可,但是每个题一般都会有一些限制,比如这个题,它求的是含有49的数字有多少个,这样求很不方便,所以我们求没有49的数字有多少个,那么枚举状态的时候就要加上一维,来表示上一位数字是不是4,(因为上一位数字是否是4会对结果造成直接的影响)。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
typedef long long ll;
ll dp[25][2];
int num[25];
ll dfs(int len,bool if4,bool limit)
{
	if(len==0)
		return 1;
	if(dp[len][if4] && !limit)
		return dp[len][if4];
	ll cnt=0,top=(limit?num[len]:9);
	for(int i=0;i<=top;i++)
	{
		if(if4&&i==9)
			continue;
		cnt+=dfs(len-1,i==4,i==top&&limit);
	}
	if(!limit)
		dp[len][if4]=cnt;
	return cnt;
}
ll solve(ll n)
{
	int k=1;
	while(n)
	{
		num[k++]=n%10;
		n/=10;
	}
	k--;
	return dfs(k,false,true);
}
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		ll n;
		cin>>n;
		cout<<n+1-solve(n)<<endl;   //减去的时候多减了一个0,要把它加上
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值